(B2) FatalBackendException: Bucket cannot be created

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

(B2) FatalBackendException: Bucket cannot be created

duplicity-talk mailing list
Hello,

Been getting this for some while--
FatalBackendException: Bucket cannot be created

Bucket does exist and was happy being used for backups for a year
previous. Error now happens on all actions, cannot access bucket to do
anything at all. Funny thing but I didnot change my version or update
software packages but B2 said they have no problems either so I'm not
sure what really change to cause this. I can't find only a single
refernce to this error on the web promising a fix in new version (of
duplicity?)

Getting desperate I try just set up a new empty bucket but same error.
So duplicity can not talk to B2 any longer. Can anyone help?

v0.7.06 (best available from apt-get)

Backend error detail: Traceback (most recent call last):
   File "/usr/bin/duplicity", line 1532, in <module>
     with_tempdir(main)
   File "/usr/bin/duplicity", line 1526, in with_tempdir
     fn()
   File "/usr/bin/duplicity", line 1364, in main
     action = commandline.ProcessCommandLine(sys.argv[1:])
   File "/usr/lib/python2.7/dist-packages/duplicity/commandline.py", line
1108, in ProcessCommandLine
     globals.backend = backend.get_backend(args[0])
   File "/usr/lib/python2.7/dist-packages/duplicity/backend.py", line
223, in get_backend
     obj = get_backend_object(url_string)
   File "/usr/lib/python2.7/dist-packages/duplicity/backend.py", line
209, in get_backend_object
     return factory(pu)
   File
"/usr/lib/python2.7/dist-packages/duplicity/backends/par2backend.py",
line 48, in __init__
     self.wrapped_backend =
backend.get_backend_object(parsed_url.url_string)
   File "/usr/lib/python2.7/dist-packages/duplicity/backend.py", line
209, in get_backend_object
     return factory(pu)
   File
"/usr/lib/python2.7/dist-packages/duplicity/backends/b2backend.py", line
80, in __init__
     raise FatalBackendException("Bucket cannot be created")
FatalBackendException: Bucket cannot be created

_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk
Reply | Threaded
Open this post in threaded view
|

Re: (B2) FatalBackendException: Bucket cannot be created

duplicity-talk mailing list
On 9/16/2018 1:03, MRob via Duplicity-talk wrote:

> Hello,
>
> Been getting this for some while--
> FatalBackendException: Bucket cannot be created
>
> Bucket does exist and was happy being used for backups for a year previous. Error now happens on all actions, cannot access bucket to do anything at all. Funny thing but I didnot change my version or update software packages but B2 said they have no problems either so I'm not sure what really change to cause this. I can't find only a single refernce to this error on the web promising a fix in new version (of duplicity?)
>
> Getting desperate I try just set up a new empty bucket but same error. So duplicity can not talk to B2 any longer. Can anyone help?
>
> v0.7.06 (best available from apt-get)
>
> Backend error detail: Traceback (most recent call last):
>   File "/usr/bin/duplicity", line 1532, in <module>
>     with_tempdir(main)
SNIP
>   File "/usr/lib/python2.7/dist-packages/duplicity/backends/b2backend.py", line 80, in __init__
>     raise FatalBackendException("Bucket cannot be created")
> FatalBackendException: Bucket cannot be created

hey Mrob,

searching reveals this is a know issue eg.
  https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=901590

there was also a non-related B2 fix in duplicity 0.7.18.. so you may want to either update your versions (duplicity/B2) manually to the latest greatest

and/or

patch as described in the debian bug tracker.

if that helps it might make sense to provide a patch here.. ede/duply.net

_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk
Reply | Threaded
Open this post in threaded view
|

Re: (B2) FatalBackendException: Bucket cannot be created

duplicity-talk mailing list
Thank you! I couldnt find the link as you did, it was waht I needed.
Patch worked as is, and easier to retain the old version because newest
version seem to require pip b2 package installed separate? This is big
problem in its own because pip2 is hard to install. Its really huge
hassle that duplicity is not python3.

So I leave duplicty at old version and go with the patch you found thank
you so much

On 2018-09-16 10:19, [hidden email] wrote:

> On 9/16/2018 1:03, MRob via Duplicity-talk wrote:
>> Hello,
>>
>> Been getting this for some while--
>> FatalBackendException: Bucket cannot be created
>>
>> Bucket does exist and was happy being used for backups for a year
>> previous. Error now happens on all actions, cannot access bucket to do
>> anything at all. Funny thing but I didnot change my version or update
>> software packages but B2 said they have no problems either so I'm not
>> sure what really change to cause this. I can't find only a single
>> refernce to this error on the web promising a fix in new version (of
>> duplicity?)
>>
>> Getting desperate I try just set up a new empty bucket but same error.
>> So duplicity can not talk to B2 any longer. Can anyone help?
>>
>> v0.7.06 (best available from apt-get)
>>
>> Backend error detail: Traceback (most recent call last):
>>   File "/usr/bin/duplicity", line 1532, in <module>
>>     with_tempdir(main)
> SNIP
>>   File
>> "/usr/lib/python2.7/dist-packages/duplicity/backends/b2backend.py",
>> line 80, in __init__
>>     raise FatalBackendException("Bucket cannot be created")
>> FatalBackendException: Bucket cannot be created
>
> hey Mrob,
>
> searching reveals this is a know issue eg.
>   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=901590
>
> there was also a non-related B2 fix in duplicity 0.7.18.. so you may
> want to either update your versions (duplicity/B2) manually to the
> latest greatest
>
> and/or
>
> patch as described in the debian bug tracker.
>
> if that helps it might make sense to provide a patch here..
> ede/duply.net

_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk
Reply | Threaded
Open this post in threaded view
|

Re: (B2) FatalBackendException: Bucket cannot be created

duplicity-talk mailing list
This was fixed in 0.7.18.1.  A previous bug fix had to be backed out that caused problems with directory names.

Please upgrade to fix this problem.

On Sun, Sep 16, 2018 at 5:17 PM MRob via Duplicity-talk <[hidden email]> wrote:
Thank you! I couldnt find the link as you did, it was waht I needed.
Patch worked as is, and easier to retain the old version because newest
version seem to require pip b2 package installed separate? This is big
problem in its own because pip2 is hard to install. Its really huge
hassle that duplicity is not python3.

So I leave duplicty at old version and go with the patch you found thank
you so much

On 2018-09-16 10:19, [hidden email] wrote:
> On 9/16/2018 1:03, MRob via Duplicity-talk wrote:
>> Hello,
>>
>> Been getting this for some while--
>> FatalBackendException: Bucket cannot be created
>>
>> Bucket does exist and was happy being used for backups for a year
>> previous. Error now happens on all actions, cannot access bucket to do
>> anything at all. Funny thing but I didnot change my version or update
>> software packages but B2 said they have no problems either so I'm not
>> sure what really change to cause this. I can't find only a single
>> refernce to this error on the web promising a fix in new version (of
>> duplicity?)
>>
>> Getting desperate I try just set up a new empty bucket but same error.
>> So duplicity can not talk to B2 any longer. Can anyone help?
>>
>> v0.7.06 (best available from apt-get)
>>
>> Backend error detail: Traceback (most recent call last):
>>   File "/usr/bin/duplicity", line 1532, in <module>
>>     with_tempdir(main)
> SNIP
>>   File
>> "/usr/lib/python2.7/dist-packages/duplicity/backends/b2backend.py",
>> line 80, in __init__
>>     raise FatalBackendException("Bucket cannot be created")
>> FatalBackendException: Bucket cannot be created
>
> hey Mrob,
>
> searching reveals this is a know issue eg.
>   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=901590
>
> there was also a non-related B2 fix in duplicity 0.7.18.. so you may
> want to either update your versions (duplicity/B2) manually to the
> latest greatest
>
> and/or
>
> patch as described in the debian bug tracker.
>
> if that helps it might make sense to provide a patch here..
> ede/duply.net

_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk

_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk