Bug Report - Parameter -c doesn't work if already running on linux

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug Report - Parameter -c doesn't work if already running on linux

Colin Conway
Hi,

I just upgraded to Xubuntu 20.04 which has Linphone 3.12.0 in it's repos, from 18.04 which had 3.6.1.

I transferred a script I use that passes highlighted phone numbers to Linphone, but it no longer works.

I tracked the issue down to the '-c' flag no longer working when Linphone is already running.

If I run this command:

linphone -c "3034997111"

...Linphone opens and calls the Speaking Clock as expected.

However, if I have Linphone running already and run the same command it outputs the following text:

** Message: 14:44:29.951: There is already a running instance.
** Message: 14:44:29.951: Message to running instance sent.

** (linphone:265771): WARNING **: 14:44:29.951: Another running instance of Linphone has been detected. It has been woken-up.

** (linphone:265771): WARNING **: 14:44:29.951: This instance is going to exit now.

...but the existing Linphone instance does nothing

I tried starting Linphone using the '--verbose' flag, then running the command to make the call; the original instance output this:

** Message: 15:00:50.381: Received wakeup command with arg 23034997111

...so it appears that the message is getting through, it's just being ignored. Is the extra '2' at the beginning of the number a parameter or an error?


Also, is it possible to get the keypad button back on the window; it's very inconvenient to have to go through the menu to turn it on and off.
Even just a keyboard shortcut would be better than what you have, but getting the button back would be best.  =) 

Thanks!
Colin =)

_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users