Compilation error.

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Compilation error.

Γιώργος Κωστόπουλος
I tried to compile the last stable version, on a Debian oldstable x64
based system.
(After installing the dependencies) ,configure complete successfully,
but make gave me error "recipe for target 'Proxy.o' failed".
I think I'll play it, on another system. Just reporting it.

Console output was very long,  so I couldn't paste it here. Actually I
faced difficulties, with the usual paste online services too.
Still, one can see it, downloading the zipped file here:
https://drive.google.com/file/d/1wbYi7a9CE0TYAeuxxag5ARxpWMDGSKA5/view?usp=sharing

Have a nice, creative and healthy 2020!  :-)
G.

Reply | Threaded
Open this post in threaded view
|

Re: Compilation error.

Andreas Lochmann-2

Hi,

I assume you try to compile the source code you found at
nongnu.org/enigma, revision 2513. This code is a little outdated and
might not compile with the latest versions of gcc. You might want to try
the github-version. Go to
   https://github.com/Enigma-Game/Enigma
Below the pink bar, you find an entry "Branch:". Make sure that it
states "master". Then click on "Clone or download", "Download ZIP". This
will give you a more recent version of the 1.21-source code.

If you know how to use git, feel free to use it instead :-)

Happy New Year to everyone on the list!

Best,
Andreas


Am 06.01.20 um 03:25 schrieb Γιώργος Κωστόπουλος:

> I tried to compile the last stable version, on a Debian oldstable x64
> based system.
> (After installing the dependencies) ,configure complete successfully,
> but make gave me error "recipe for target 'Proxy.o' failed".
> I think I'll play it, on another system. Just reporting it.
>
> Console output was very long,  so I couldn't paste it here. Actually I
> faced difficulties, with the usual paste online services too.
> Still, one can see it, downloading the zipped file here:
> https://drive.google.com/file/d/1wbYi7a9CE0TYAeuxxag5ARxpWMDGSKA5/view?usp=sharing
>
> Have a nice, creative and healthy 2020!  :-)
> G.
>

Reply | Threaded
Open this post in threaded view
|

Re: Compilation error.

Γιώργος Κωστόπουλος
Στις Δευ, 6 Ιαν 2020 στις 4:29 μ.μ., ο/η Andreas Lochmann
<[hidden email]> έγραψε:
>
>
> Hi,
>
> I assume you try to compile the source code you found at
> nongnu.org/enigma, revision 2513.

Indeed!

> This code is a little outdated and
> might not compile with the latest versions of gcc. You might want to try
> the github-version. Go to
>    https://github.com/Enigma-Game/Enigma
> Below the pink bar, you find an entry "Branch:". Make sure that it
> states "master". Then click on "Clone or download", "Download ZIP". This
> will give you a more recent version of the 1.21-source code.
>
> If you know how to use git, feel free to use it instead :-)
>

I'm not a huge fan of git. I prefer the release files, over constantly
updates.  :-)
I know how it works, but I uninstalled it...ages ago!  :-)

I downloaded the latest dev code and indeed, this time configure AND
make complete successfully!
(As root) "make install" failed (and the bash output is here):
https://drive.google.com/file/d/1ynJKnTlGAPRq-emj1C33OY2VwdIa7Dyq/view?usp=sharing

However, Enigma plays locally (from compilation directory) as
expected, although seems to have some difficulties.
Eg. Translations, don't seems to work (although it compiles with nls enabled).

> Happy New Year to everyone on the list!
>
> Best,
> Andreas
>
>
THANKS Andreas!  :-)
G.