Compiling Enigma on Windows XP with MinGW-MSys

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Compiling Enigma on Windows XP with MinGW-MSys

Harry Bruder
Hi,

has anyone succeeded building Enigma under Windows XP using MinGW-MSys?
I have tried for several hours during the last days but I can't get it
done. In particular I've got problems with Xerces-C. Somewhere when
running the configure or make script of v3.0.1 the "Blue Screen Of
Death" shows up with an 0x0A error message "IRQL_NOT_LESS_OR_EQUAL". The
same happens after installing the precompiled VC binaries of v3.01 to
MinGW and then running the Enigma configure script. I managed to
configure and make the 2.8.0 version of Xerces, but then I get an error
message from the Enigma configure file: "checking for Xerces 3.0
experimental version... Not found... error: xerces is required to
compile Enigma." Any ideas what's going wrong?

Best wishes,
Harry



_______________________________________________
Enigma-devel mailing list
[hidden email]
http://lists.nongnu.org/mailman/listinfo/enigma-devel
Reply | Threaded
Open this post in threaded view
|

Re: Compiling Enigma on Windows XP with MinGW-MSys

Ronald Lamprecht
Hi,

Harry Bruder schrieb:

> has anyone succeeded building Enigma under Windows XP using MinGW-MSys?
> I have tried for several hours during the last days but I can't get it
> done. In particular I've got problems with Xerces-C. Somewhere when
> running the configure or make script of v3.0.1 the "Blue Screen Of
> Death" shows up with an 0x0A error message "IRQL_NOT_LESS_OR_EQUAL". The
> same happens after installing the precompiled VC binaries of v3.01 to
> MinGW and then running the Enigma configure script. I managed to
> configure and make the 2.8.0 version of Xerces, but then I get an error
> message from the Enigma configure file: "checking for Xerces 3.0
> experimental version... Not found... error: xerces is required to
> compile Enigma." Any ideas what's going wrong?

Xerces 2.7 did not compile on MinGW, so I did use the upcoming 3.0 trunk
that has been more stable and elaborated than the 2.* branch for quite a
time. I never checked 2.8 on Windows - it may work but I don't think it
is worth trying.

A complete configuration of MinGW and matching tool versions is listed
in the REQUIREMENTS file. Yes I am still using an old MinGW
configuration, because the current version did cause serious problems
with the exception handling. Because it is a very nasty business to
check these critical parts I did stick to the configuration that is well
known to work.

Please report any stable configuration that you tested throughly by long
term tests and repeated exception behaviour tests.

Greets,

Ronald


_______________________________________________
Enigma-devel mailing list
[hidden email]
http://lists.nongnu.org/mailman/listinfo/enigma-devel