Duplicity 0.8.00 Released

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Duplicity 0.8.00 Released

duplicity-talk mailing list
Hi,

A major release here!  There has been a lot of work to get to this point, and a fair bit of work still remains to be done.  You can see the full details of the changes at Milestone 0.8.00, but the two really major changes are:
  • Much better Unicode support
  • Python 2/3 support (Python 2.7, Python 3.5+)
As far as we can tell, all series-7 changes during this timeframe were made to series-8 as well.  Please let us know if we missed anything.

As with any dot-zero release, there will be bugs.  Please file a bug report if you find one.  If you could, also include a suggested patch or merge.

A great deal of thanks goes out to the contributors!  None of this would be possible without their continued support.

...Thanks,
...Ken


_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk
Reply | Threaded
Open this post in threaded view
|

Re: Duplicity 0.8.00 Released

duplicity-talk mailing list
Hello all,

On May 29 2019, at 6:40 pm, Kenneth Loafman via Duplicity-talk <[hidden email]> wrote:
A major release here!  There has been a lot of work to get to this point, and a fair bit of work still remains to be done.  You can see the full details of the changes at Milestone 0.8.00, but the two really major changes are:

I have now packaged up version 0.8.00 as a snap. You can install it by typing:
snap install duplicity --classic --beta
Please uninstall your current version of duplicity to ensure you are using the snap instead of one from apt etc.
(This will work out of the box on nearly all versions of Ubuntu. If you use a different distro and have never installed snaps before, visit this page:

This includes the latest duplicity and all dependencies wrapped up in a self-contained bundle. You should not need to install anything else for this to work (including for all backends). As Ken says, this is the first 0.8-series release, so expect issues and test it out on data you can afford to lose (if it comes to that).

If you do test this, it would be very helpful if you could please let me know, even if the only feedback is that all worked as expected (privately or on the list is fine).

If you are giving any feedback, please also give the output of:
which duplicity
and
snap list | grep duplicity
and let me know which backends you used.

Kind regards,

Aaron



_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk