Duplicity 0.8.12 Released

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Duplicity 0.8.12 Released

duplicity-talk mailing list
Hi,

Just more bug fixes.

You can see the full details of the changes at Milestone 0.8.12.

There are a few download options:
NOTE: UNinstall duplicity first if it was installed via the distribution repository.  For Ubuntu, that would be "sudo apt-get purge duplicity".

...Thanks,
...Ken

_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk
Reply | Threaded
Open this post in threaded view
|

Re: Duplicity 0.8.12 Released

duplicity-talk mailing list
I implemented this version today updating my fink package manager.  There were the normal number of warnings due to Mac OS doing something strange to unicode between when my OS was released several years ago and today.

But there is also a warning in the test suite that is new, probably due to my use of Python 3.6 instead of 2.7.

=============================== warnings summary ===============================
/sw/lib/python3.7/site-packages/past/builtins/misc.py:4
  /sw/lib/python3.7/site-packages/past/builtins/misc.py:4: DeprecationWarning: Using or importing the ABCs from 'collections' instead of from 'collections.abc' is deprecated since Python 3.3,and in 3.9 it will stop working
    from collections import Mapping

====== 5 failed, 423 passed, 12 skipped, 1 warnings in 1068.69s (0:17:48) ======

I quickly got lost in the relative and absolute import details but it seems that the “from” command needs a module as well as a package in the description???

-Scott (not a python expert)

On Mar 19, 2020, at 4:43 PM, Kenneth Loafman via Duplicity-talk <[hidden email]> wrote:

Hi,

Just more bug fixes.



_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk
Reply | Threaded
Open this post in threaded view
|

Re: Duplicity 0.8.12 Released

duplicity-talk mailing list
Thanks for the info.  It's on my list to fix.

...Ken


On Sun, Apr 26, 2020 at 5:16 PM Scott Hannahs via Duplicity-talk <[hidden email]> wrote:
I implemented this version today updating my fink package manager.  There were the normal number of warnings due to Mac OS doing something strange to unicode between when my OS was released several years ago and today.

But there is also a warning in the test suite that is new, probably due to my use of Python 3.6 instead of 2.7.

=============================== warnings summary ===============================
/sw/lib/python3.7/site-packages/past/builtins/misc.py:4
  /sw/lib/python3.7/site-packages/past/builtins/misc.py:4: DeprecationWarning: Using or importing the ABCs from 'collections' instead of from 'collections.abc' is deprecated since Python 3.3,and in 3.9 it will stop working
    from collections import Mapping

====== 5 failed, 423 passed, 12 skipped, 1 warnings in 1068.69s (0:17:48) ======

I quickly got lost in the relative and absolute import details but it seems that the “from” command needs a module as well as a package in the description???

-Scott (not a python expert)

On Mar 19, 2020, at 4:43 PM, Kenneth Loafman via Duplicity-talk <[hidden email]> wrote:

Hi,

Just more bug fixes.


_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk

_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk