Duplicity going very slow (170KB/s)

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Duplicity going very slow (170KB/s)

duplicity-talk mailing list
Hi all,

I'm having a very slow speed when making a backup with Duplicity (~170KB/s) and 100% CPU usage.

Origin device:
  • Debian testing up to date (no GUI, LUKS, soft-raid0)
  • Duplicity¬†0.7.13.1-2
  • Intel J1900
  • 4GB RAM
  • 2x 250GB SSD
Destination device:
  • Raspberry Pi Zero W
  • Raspbian up to date
  • USB 2,5" WD HDD 2TB (destination drive)
But also tested to localhost with same result.

The testing file is a 500MB file with /dev/urandom content.

My first try with Duplicity was:
  • duplicity foo scp://REMOTEUSER@REMOTEIP:REMOTEPORT//path/to/destination/bar --ssh-askpass
After the low-speed results, I tried:
  • duplicity foo scp://REMOTEUSER@REMOTEIP:REMOTEPORT//path/to/destination/bar --ssh-askpass -v9 --no-compression --no-encryption
  • (and other combinations, including --gpg-options without encryption and compression)

Always got the same: ~170KB/s.

I encrypted the file with GPG and I got ~25MB/s. Sending the same file directly with SCP to the Raspberry Pi was ~2.5MB/s.

I can't find why duplicity speed is only 170KB/s.

Attached you can find one -v9 log as example. Hope it helps.

Any ideas why is so slow?

Thank you very much!
S.

_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk

verbose9.txt (12K) Download Attachment