Duply: forcing version of GPG

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Duply: forcing version of GPG

duplicity-talk mailing list
Hello all (particularly Ede),

I have a key with a subkey that only works in gpg2, not gpg1 and I am struggling to force Duply to use a particular GPG version.

I have set the following in duply:
===
# uncomment and set a file path or name force duply to use this gpg executable
# available in duplicity 0.7.04 and above (currently unreleased 06/2015)
GPG='/usr/bin/gpg2'
#GPG='/usr/local/gpg-2.1/bin/gpg'
===
(and this is the correct path, tested by copy-pasting that path with --version:
/usr/bin/gpg2 --version
gpg (GnuPG) 2.1.11
)

But running Duply gives the following:
duply storage backup
Start duply v2.0.4, time is 2018-04-14 22:28:06.
Using profile '/home/mythbuntu/.duply/storage'.
Using installed duplicity version 0.7.17, python 2.7.12, gpg 1.4.20 (Home: ~/.gnupg), awk 'mawk 1.3.3 Nov 1996, Copyright (C) Michael D. Brennan', grep 'grep (GNU grep) 2.25', bash '4.3.48(1)-release (x86_64-pc-linux-gnu)'.

suggesting that gpg 1.4 is being used.

Any ideas?

Kind regards,

Aaron





_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk
Reply | Threaded
Open this post in threaded view
|

Re: Duply: forcing version of GPG

duplicity-talk mailing list
hey Aaron,

mhmm, works for me in my test setup.. can you run your duply command with --preview to check that the gpg option is set properly for duplicity?

maybe some weird issue w/ the version detection. would you be willing to run some test scripts?

..ede/duply.net

On 4/14/2018 23:31, Aaron Whitehouse via Duplicity-talk wrote:

> Hello all (particularly Ede),
>
> I have a key with a subkey that only works in gpg2, not gpg1 and I am struggling to force Duply to use a particular GPG version.
>
> I have set the following in duply:
> ===
> # uncomment and set a file path or name force duply to use this gpg executable
> # available in duplicity 0.7.04 and above (currently unreleased 06/2015)
> GPG='/usr/bin/gpg2'
> #GPG='/usr/local/gpg-2.1/bin/gpg'
> ===
> (and this is the correct path, tested by copy-pasting that path with --version:
> /usr/bin/gpg2 --version
> gpg (GnuPG) 2.1.11
> )
>
> But running Duply gives the following:
> duply storage backup
> Start duply v2.0.4, time is 2018-04-14 22:28:06.
> Using profile '/home/mythbuntu/.duply/storage'.
> Using installed duplicity version 0.7.17, python 2.7.12, gpg 1.4.20 (Home: ~/.gnupg), awk 'mawk 1.3.3 Nov 1996, Copyright (C) Michael D. Brennan', grep 'grep (GNU grep) 2.25', bash '4.3.48(1)-release (x86_64-pc-linux-gnu)'.
>
> suggesting that gpg 1.4 is being used.
>
> Any ideas?
>
> Kind regards,
>
> Aaron
>
>
>
>
>
>
> _______________________________________________
> Duplicity-talk mailing list
> [hidden email]
> https://lists.nongnu.org/mailman/listinfo/duplicity-talk
>


_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk