Error while compiling svn gchemutils

classic Classic list List threaded Threaded
4 messages Options
A G
Reply | Threaded
Open this post in threaded view
|

Error while compiling svn gchemutils

A G
Hello,

I have been running into an error while compiling the svn verstion of gnome-chemistry-utils.  It seems to be having a problem with GtkUIManager:

make[4]: Entering directory '/home/officergris/Eclipse/Workspace_gchemutils/gchemutils/libs/gcugtk'
  CXX      chem3dapplication.lo
In file included from chem3dapplication.cc:31:0:
molecule.h:72:27: error: 'GtkUIManager' has not been declared
  void BuildDatabasesMenu (GtkUIManager *UIManager, char const *path, char const *path_end);

I have googled around a bit to no avail, and have even tried switching the gtk checking from 3.xx to 2.xx since GtkUIManager has been deprecated.  I can't find anything that looks like it would make a difference using diff, either.  Has anyone else run into this problem, or have an idea about how to fix it?

I am running Arch Linux, gtk+-2.0 = 2.24.22, gtk+-3.0 = 3.10.2, glibc = 2.18.9

Thanks!



_______________________________________________
Gchemutils-main mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/gchemutils-main
Reply | Threaded
Open this post in threaded view
|

Re: Error while compiling svn gchemutils

Jean Brefort-2
Hello,

GtkUIManager was deprecated in gtk+-3.10. It's not clear how it should
be replaced. For the time being, just remove GTK_DISABLE_DEPRECATED from
the Makefiles.

Hope this helps,
Jean

Le dimanche 10 novembre 2013 à 09:02 -0600, A G a écrit :

> Hello,
>
> I have been running into an error while compiling the svn verstion of
> gnome-chemistry-utils.  It seems to be having a problem with
> GtkUIManager:
>
> make[4]: Entering directory
> '/home/officergris/Eclipse/Workspace_gchemutils/gchemutils/libs/gcugtk'
>   CXX      chem3dapplication.lo
> In file included from chem3dapplication.cc:31:0:
> molecule.h:72:27: error: 'GtkUIManager' has not been declared
>   void BuildDatabasesMenu (GtkUIManager *UIManager, char const *path,
> char const *path_end);
>
>
> I have googled around a bit to no avail, and have even tried switching
> the gtk checking from 3.xx to 2.xx since GtkUIManager has been
> deprecated.  I can't find anything that looks like it would make a
> difference using diff, either.  Has anyone else run into this problem,
> or have an idea about how to fix it?
>
>
> I am running Arch Linux, gtk+-2.0 = 2.24.22, gtk+-3.0 = 3.10.2, glibc
> = 2.18.9
>
>
> Thanks!
>
>
>
> _______________________________________________
> Gchemutils-main mailing list
> [hidden email]
> https://lists.nongnu.org/mailman/listinfo/gchemutils-main



_______________________________________________
Gchemutils-main mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/gchemutils-main
Reply | Threaded
Open this post in threaded view
|

Re: Error while compiling svn gchemutils

Jean Brefort-2
Actually you have to remove it from configure.ac, line 166.

Le dimanche 10 novembre 2013 à 18:55 +0100, Jean Bréfort a écrit :

> Hello,
>
> GtkUIManager was deprecated in gtk+-3.10. It's not clear how it should
> be replaced. For the time being, just remove GTK_DISABLE_DEPRECATED from
> the Makefiles.
>
> Hope this helps,
> Jean
>
> Le dimanche 10 novembre 2013 à 09:02 -0600, A G a écrit :
> > Hello,
> >
> > I have been running into an error while compiling the svn verstion of
> > gnome-chemistry-utils.  It seems to be having a problem with
> > GtkUIManager:
> >
> > make[4]: Entering directory
> > '/home/officergris/Eclipse/Workspace_gchemutils/gchemutils/libs/gcugtk'
> >   CXX      chem3dapplication.lo
> > In file included from chem3dapplication.cc:31:0:
> > molecule.h:72:27: error: 'GtkUIManager' has not been declared
> >   void BuildDatabasesMenu (GtkUIManager *UIManager, char const *path,
> > char const *path_end);
> >
> >
> > I have googled around a bit to no avail, and have even tried switching
> > the gtk checking from 3.xx to 2.xx since GtkUIManager has been
> > deprecated.  I can't find anything that looks like it would make a
> > difference using diff, either.  Has anyone else run into this problem,
> > or have an idea about how to fix it?
> >
> >
> > I am running Arch Linux, gtk+-2.0 = 2.24.22, gtk+-3.0 = 3.10.2, glibc
> > = 2.18.9
> >
> >
> > Thanks!
> >
> >
> >
> > _______________________________________________
> > Gchemutils-main mailing list
> > [hidden email]
> > https://lists.nongnu.org/mailman/listinfo/gchemutils-main
>
>
>
> _______________________________________________
> Gchemutils-main mailing list
> [hidden email]
> https://lists.nongnu.org/mailman/listinfo/gchemutils-main



_______________________________________________
Gchemutils-main mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/gchemutils-main
A G
Reply | Threaded
Open this post in threaded view
|

Re: Error while compiling svn gchemutils

A G
That worked wonders.  Just compile warnings now, but that is to be expected.  Thank you!


On Sun, Nov 10, 2013 at 11:57 AM, Jean Bréfort <[hidden email]> wrote:
Actually you have to remove it from configure.ac, line 166.

Le dimanche 10 novembre 2013 à 18:55 +0100, Jean Bréfort a écrit :
> Hello,
>
> GtkUIManager was deprecated in gtk+-3.10. It's not clear how it should
> be replaced. For the time being, just remove GTK_DISABLE_DEPRECATED from
> the Makefiles.
>
> Hope this helps,
> Jean
>
> Le dimanche 10 novembre 2013 à 09:02 -0600, A G a écrit :
> > Hello,
> >
> > I have been running into an error while compiling the svn verstion of
> > gnome-chemistry-utils.  It seems to be having a problem with
> > GtkUIManager:
> >
> > make[4]: Entering directory
> > '/home/officergris/Eclipse/Workspace_gchemutils/gchemutils/libs/gcugtk'
> >   CXX      chem3dapplication.lo
> > In file included from chem3dapplication.cc:31:0:
> > molecule.h:72:27: error: 'GtkUIManager' has not been declared
> >   void BuildDatabasesMenu (GtkUIManager *UIManager, char const *path,
> > char const *path_end);
> >
> >
> > I have googled around a bit to no avail, and have even tried switching
> > the gtk checking from 3.xx to 2.xx since GtkUIManager has been
> > deprecated.  I can't find anything that looks like it would make a
> > difference using diff, either.  Has anyone else run into this problem,
> > or have an idea about how to fix it?
> >
> >
> > I am running Arch Linux, gtk+-2.0 = 2.24.22, gtk+-3.0 = 3.10.2, glibc
> > = 2.18.9
> >
> >
> > Thanks!
> >
> >
> >
> > _______________________________________________
> > Gchemutils-main mailing list
> > [hidden email]
> > https://lists.nongnu.org/mailman/listinfo/gchemutils-main
>
>
>
> _______________________________________________
> Gchemutils-main mailing list
> [hidden email]
> https://lists.nongnu.org/mailman/listinfo/gchemutils-main




_______________________________________________
Gchemutils-main mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/gchemutils-main