GChemPaint and gtk+-3.20

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

GChemPaint and gtk+-3.20

Jean Brefort-2
Hi,

Looks like GChemPaint has serious display issues when run over gtk+-
3.20 (gray background in the main window and, more critical, invisible
buttons in the toolbox).

As things work with the unstable branch (svn trunk, not 0.15.1), the
easy way to fix it is to backport some code from it to the stable
branch. This means API instability, but it should not be an issue since
the libraries are not used elsewhere. And while there I think I might
backport new features which seem already stable such as support for
math equation display using lasem. Would adding this new dependency an
issue for some packagers? I know there is a lasem rpm in fedora, but
nothing in debian (although there is an old request for it).

Best regards,
Jean

_______________________________________________
Gchemutils-main mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/gchemutils-main
Reply | Threaded
Open this post in threaded view
|

Re: GChemPaint and gtk+-3.20

Julian Sikorski-2
W dniu 01.05.2016 o 15:47, Jean Bréfort pisze:

> Hi,
>
> Looks like GChemPaint has serious display issues when run over gtk+-
> 3.20 (gray background in the main window and, more critical, invisible
> buttons in the toolbox).
>
> As things work with the unstable branch (svn trunk, not 0.15.1), the
> easy way to fix it is to backport some code from it to the stable
> branch. This means API instability, but it should not be an issue since
> the libraries are not used elsewhere. And while there I think I might
> backport new features which seem already stable such as support for
> math equation display using lasem. Would adding this new dependency an
> issue for some packagers? I know there is a lasem rpm in fedora, but
> nothing in debian (although there is an old request for it).
>
> Best regards,
> Jean
>
> _______________________________________________
> Gchemutils-main mailing list
> [hidden email]
> https://lists.nongnu.org/mailman/listinfo/gchemutils-main
>
Hi Jean,

I looked for references of Lasem for fedora but I could not find any.
RPMFind only returns OpenSUSE packages. Please may you clarify where did
you see references to Fedora lasem rpm?

Best regards,
Julian

_______________________________________________
Gchemutils-main mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/gchemutils-main
Reply | Threaded
Open this post in threaded view
|

Re: GChemPaint and gtk+-3.20

Jean Brefort-2
Le samedi 07 mai 2016 à 15:51 +0200, Julian Sikorski a écrit :

> W dniu 01.05.2016 o 15:47, Jean Bréfort pisze:
> >
> > Hi,
> >
> > Looks like GChemPaint has serious display issues when run over
> > gtk+-
> > 3.20 (gray background in the main window and, more critical,
> > invisible
> > buttons in the toolbox).
> >
> > As things work with the unstable branch (svn trunk, not 0.15.1),
> > the
> > easy way to fix it is to backport some code from it to the stable
> > branch. This means API instability, but it should not be an issue
> > since
> > the libraries are not used elsewhere. And while there I think I
> > might
> > backport new features which seem already stable such as support for
> > math equation display using lasem. Would adding this new dependency
> > an
> > issue for some packagers? I know there is a lasem rpm in fedora,
> > but
> > nothing in debian (although there is an old request for it).
> >
> > Best regards,
> > Jean
> >
> > _______________________________________________
> > Gchemutils-main mailing list
> > [hidden email]
> > https://lists.nongnu.org/mailman/listinfo/gchemutils-main
> >
> Hi Jean,
>
> I looked for references of Lasem for fedora but I could not find any.
> RPMFind only returns OpenSUSE packages. Please may you clarify where
> did
> you see references to Fedora lasem rpm?
>
> Best regards,
> Julian

Hi Julian,

I found this one:
http://rpm.pbone.net/index.php3/stat/4/idpl/23801403/dir/fedora_19/com/
lasem-devel-0.4.1-7.1.i686.rpm.html

Looks like it is related to OpenSuse though.

Best regards,
Jean

_______________________________________________
Gchemutils-main mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/gchemutils-main
Reply | Threaded
Open this post in threaded view
|

Re: GChemPaint and gtk+-3.20

Julian Sikorski-2
W dniu 07.05.2016 o 16:58, Jean Brefort pisze:

> Le samedi 07 mai 2016 à 15:51 +0200, Julian Sikorski a écrit :
>> W dniu 01.05.2016 o 15:47, Jean Bréfort pisze:
>>>
>>> Hi,
>>>
>>> Looks like GChemPaint has serious display issues when run over
>>> gtk+-
>>> 3.20 (gray background in the main window and, more critical,
>>> invisible
>>> buttons in the toolbox).
>>>
>>> As things work with the unstable branch (svn trunk, not 0.15.1),
>>> the
>>> easy way to fix it is to backport some code from it to the stable
>>> branch. This means API instability, but it should not be an issue
>>> since
>>> the libraries are not used elsewhere. And while there I think I
>>> might
>>> backport new features which seem already stable such as support for
>>> math equation display using lasem. Would adding this new dependency
>>> an
>>> issue for some packagers? I know there is a lasem rpm in fedora,
>>> but
>>> nothing in debian (although there is an old request for it).
>>>
>>> Best regards,
>>> Jean
>>>
>>> _______________________________________________
>>> Gchemutils-main mailing list
>>> [hidden email]
>>> https://lists.nongnu.org/mailman/listinfo/gchemutils-main
>>>
>> Hi Jean,
>>
>> I looked for references of Lasem for fedora but I could not find any.
>> RPMFind only returns OpenSUSE packages. Please may you clarify where
>> did
>> you see references to Fedora lasem rpm?
>>
>> Best regards,
>> Julian
>
> Hi Julian,
>
> I found this one:
> http://rpm.pbone.net/index.php3/stat/4/idpl/23801403/dir/fedora_19/com/
> lasem-devel-0.4.1-7.1.i686.rpm.html
>
> Looks like it is related to OpenSuse though.
>
> Best regards,
> Jean
>
Hi Jean,

this does not look like proper Fedora package unfortunately. Moreover,
Fedora 19 is 3 releases older than the oldest supported branch.
As such, I am not in favour of adding this dependency. While I could
submit it for review, I cannot tell how long would it take to get the
package into Fedora repositories.

Best regards,
Julian

_______________________________________________
Gchemutils-main mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/gchemutils-main
Reply | Threaded
Open this post in threaded view
|

Re: GChemPaint and gtk+-3.20

Jean Brefort-2
Le samedi 07 mai 2016 à 18:33 +0200, Julian Sikorski a écrit :

> W dniu 07.05.2016 o 16:58, Jean Brefort pisze:
> >
> > Le samedi 07 mai 2016 à 15:51 +0200, Julian Sikorski a écrit :
> > >
> > > W dniu 01.05.2016 o 15:47, Jean Bréfort pisze:
> > > >
> > > >
> > > > Hi,
> > > >
> > > > Looks like GChemPaint has serious display issues when run over
> > > > gtk+-
> > > > 3.20 (gray background in the main window and, more critical,
> > > > invisible
> > > > buttons in the toolbox).
> > > >
> > > > As things work with the unstable branch (svn trunk, not
> > > > 0.15.1),
> > > > the
> > > > easy way to fix it is to backport some code from it to the
> > > > stable
> > > > branch. This means API instability, but it should not be an
> > > > issue
> > > > since
> > > > the libraries are not used elsewhere. And while there I think I
> > > > might
> > > > backport new features which seem already stable such as support
> > > > for
> > > > math equation display using lasem. Would adding this new
> > > > dependency
> > > > an
> > > > issue for some packagers? I know there is a lasem rpm in
> > > > fedora,
> > > > but
> > > > nothing in debian (although there is an old request for it).
> > > >
> > > > Best regards,
> > > > Jean
> > > >
> > > > _______________________________________________
> > > > Gchemutils-main mailing list
> > > > [hidden email]
> > > > https://lists.nongnu.org/mailman/listinfo/gchemutils-main
> > > >
> > > Hi Jean,
> > >
> > > I looked for references of Lasem for fedora but I could not find
> > > any.
> > > RPMFind only returns OpenSUSE packages. Please may you clarify
> > > where
> > > did
> > > you see references to Fedora lasem rpm?
> > >
> > > Best regards,
> > > Julian
> > Hi Julian,
> >
> > I found this one:
> > http://rpm.pbone.net/index.php3/stat/4/idpl/23801403/dir/fedora_19/
> > com/
> > lasem-devel-0.4.1-7.1.i686.rpm.html
> >
> > Looks like it is related to OpenSuse though.
> >
> > Best regards,
> > Jean
> >
> Hi Jean,
>
> this does not look like proper Fedora package unfortunately.
> Moreover,
> Fedora 19 is 3 releases older than the oldest supported branch.
> As such, I am not in favour of adding this dependency. While I could
> submit it for review, I cannot tell how long would it take to get the
> package into Fedora repositories.
>
> Best regards,
> Julian

OK, I'll make it optional then.

Best regards,
Jean

_______________________________________________
Gchemutils-main mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/gchemutils-main