Help requested to test Snap package of 0.7.19

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Help requested to test Snap package of 0.7.19

duplicity-talk mailing list
All,

I have now created a snap package for duplicity and would appreciate all of your help testing it. You can install it by typing:
snap install duplicity --classic --beta
Please uninstall your current version of duplicity to ensure you are using the snap instead of one from apt etc.
(This will work out of the box on Ubuntu. If you use a different distro and have never installed snaps before, visit this page:

This includes the latest duplicity and all dependencies wrapped up in a self-contained bundle. You should not need to install anything else for this to work (including for all backends).

If you do test this, it would be very helpful if you could please let me know, even if the only feedback is that all worked as expected (privately or on the list is fine).

If you are giving any feedback, please also give the output of:
which duplicity
and
snap list | grep duplicity

Many thanks,

Aaron

_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk
Reply | Threaded
Open this post in threaded view
|

Re: Help requested to test Snap package of 0.7.19

duplicity-talk mailing list
All,

On May 8 2019, at 9:01 pm, Aaron Whitehouse via Duplicity-talk <[hidden email]> wrote:

All,

I have now created a snap package for duplicity and would appreciate all of your help testing it. You can install it by typing:
snap install duplicity --classic --beta

Note that I have tested this with a number of backup sets where the archives are stored on the local disk and everything is working very well. The only issue I have found so far is that duply does not work when called from a systemd service (it does not look in the correct place for the duplicity binary; duply works perfectly when used normally).

I have not tested the backends, so feedback on those would be extremely helpful.

Kind regards,

Aaron


_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk
Reply | Threaded
Open this post in threaded view
|

Re: Help requested to test Snap package of 0.7.19

duplicity-talk mailing list
On 08.05.2019 22:12, Aaron Whitehouse via Duplicity-talk wrote:
> The only issue I have found so far is that duply does not work when called from a systemd service (it does not look in the correct place for the duplicity binary; duply works perfectly when used normally).

Aaron,

can you explain or provide a patch for duply?.. ede/duply.net

_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk