Linphone 4.2.3 starting issue on MacOs 10.12.6

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Linphone 4.2.3 starting issue on MacOs 10.12.6

Antonella Renna
Hello, I'm trying to install your product on my Macbook Air Mid 2011, version 10.12.6 (Sierra).
Downloaded several timesvthe installer .dmg
Unpacked and installed at  least 5 times, the result is always the same as follows👇

Process:               linphone [1172]
Path:                  /Applications/Linphone.app/Contents/MacOS/linphone
Identifier:            com.belledonnecommunications.linphone
Version:               4.2.3 (4.2.3)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           linphone [1172]
User ID:               502

Date/Time:             2020-11-19 13:42:58.485 +0100
OS Version:            Mac OS X 10.12.6 (16G2136)
Report Version:        12
Anonymous UUID:        A6AE3F19-4A43-DB35-C435-3003B9531714

Sleep/Wake UUID:       76FC913D-8CFD-492F-80CF-C8AC5A824D07

Time Awake Since Boot: 10000 seconds
Time Since Wake:       830 seconds

System Integrity Protection: enabled

Crashed Thread:        0

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Reason:    DYLD, [0x1] Library missing

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: @rpath/bctoolbox.framework/Versions/A/bctoolbox
  Referenced from: /Applications/Linphone.app/Contents/MacOS/linphone

  Reason: no suitable image found.  Did find:
/Applications/Linphone.app/Contents/MacOS/../Frameworks/bctoolbox.framework/Versions/A/bctoolbox: code signing blocked mmap() of '/Applications/Linphone.app/Contents/MacOS/../Frameworks/bctoolbox.framework/Versions/A/bctoolbox'

Binary Images:
       0x105619000 -        0x105b97ff7 +com.belledonnecommunications.linphone (4.2.3 - 4.2.3) <3E38F71B-8E41-3AD0-9D26-B43F36679CD0> /Applications/Linphone.app/Contents/MacOS/linphone
       0x107ec9000 -        0x107f06dc7  dyld (434) <33DB4E37-BC29-37A4-92AB-30328E66A8FA> /usr/lib/dyld

Model: MacBookAir4,2, BootROM 135.0.0.0.0, 2 processors, Intel Core i5, 1,7 GHz, 4 GB, SMC 1.73f66
Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In
Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1333 MHz, 0x80CE, 0x4D34373142353737334448302D4348392020
Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1333 MHz, 0x80CE, 0x4D34373142353737334448302D4348392020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xE9), Broadcom BCM43xx 1.0 (5.106.98.102.30)
Bluetooth: Version 5.0.5f7, 3 services, 17 devices, 3 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
Serial ATA Device: APPLE SSD SM128C, 121,33 GB
USB Device: USB 2.0 Bus
USB Device: FaceTime Camera (Built-in)
USB Device: Hub
USB Device: Apple Internal Keyboard / Trackpad
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: Card Reader
Thunderbolt Bus: MacBook Air, Apple Inc., 8.1

So far, it seems to be a problem "library-related".
I'm not a scientist, or a programmer. I'm a normal user.
So please, if it is possible, let me know how to make this software run on my PC.
Thanks.
Antonella.

_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users
Reply | Threaded
Open this post in threaded view
|

Re: Linphone 4.2.3 starting issue on MacOs 10.12.6

Peio Rigaux

Hello.

Sorry for the belated reply, I have been very busy in the past months.

Could you please try to install the latest version of Linphone to see if your issue is fixed ? The 4.2.5 version is available.

If it still doesn't work, it might be related to your "old" device.

I do not know how code signing works for Apple devices, so I think that I can't help you, but I can eventually ask my colleagues.

However, as the answers in community mailing list are personal contributions given on "free" time, I can't guarantee you an answer.

Can someone here test with a similar device please ?


Regards,

Peio Rigaux
Junior Software Engineer
Belledonne Communications, the company behind Linphone
Linphone.org

Le 19/11/2020 à 16:54, Antonella Renna a écrit :
Hello, I'm trying to install your product on my Macbook Air Mid 2011, version 10.12.6 (Sierra).
Downloaded several timesvthe installer .dmg
Unpacked and installed at  least 5 times, the result is always the same as follows👇

Process:               linphone [1172]
Path:                  /Applications/Linphone.app/Contents/MacOS/linphone
Identifier:            com.belledonnecommunications.linphone
Version:               4.2.3 (4.2.3)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           linphone [1172]
User ID:               502

Date/Time:             2020-11-19 13:42:58.485 +0100
OS Version:            Mac OS X 10.12.6 (16G2136)
Report Version:        12
Anonymous UUID:        A6AE3F19-4A43-DB35-C435-3003B9531714

Sleep/Wake UUID:       76FC913D-8CFD-492F-80CF-C8AC5A824D07

Time Awake Since Boot: 10000 seconds
Time Since Wake:       830 seconds

System Integrity Protection: enabled

Crashed Thread:        0

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Reason:    DYLD, [0x1] Library missing

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: @rpath/bctoolbox.framework/Versions/A/bctoolbox
  Referenced from: /Applications/Linphone.app/Contents/MacOS/linphone

  Reason: no suitable image found.  Did find:
/Applications/Linphone.app/Contents/MacOS/../Frameworks/bctoolbox.framework/Versions/A/bctoolbox: code signing blocked mmap() of '/Applications/Linphone.app/Contents/MacOS/../Frameworks/bctoolbox.framework/Versions/A/bctoolbox'

Binary Images:
       0x105619000 -        0x105b97ff7 +com.belledonnecommunications.linphone (4.2.3 - 4.2.3) <3E38F71B-8E41-3AD0-9D26-B43F36679CD0> /Applications/Linphone.app/Contents/MacOS/linphone
       0x107ec9000 -        0x107f06dc7  dyld (434) <33DB4E37-BC29-37A4-92AB-30328E66A8FA> /usr/lib/dyld

Model: MacBookAir4,2, BootROM 135.0.0.0.0, 2 processors, Intel Core i5, 1,7 GHz, 4 GB, SMC 1.73f66
Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In
Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1333 MHz, 0x80CE, 0x4D34373142353737334448302D4348392020
Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1333 MHz, 0x80CE, 0x4D34373142353737334448302D4348392020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xE9), Broadcom BCM43xx 1.0 (5.106.98.102.30)
Bluetooth: Version 5.0.5f7, 3 services, 17 devices, 3 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
Serial ATA Device: APPLE SSD SM128C, 121,33 GB
USB Device: USB 2.0 Bus
USB Device: FaceTime Camera (Built-in)
USB Device: Hub
USB Device: Apple Internal Keyboard / Trackpad
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: Card Reader
Thunderbolt Bus: MacBook Air, Apple Inc., 8.1

So far, it seems to be a problem "library-related".
I'm not a scientist, or a programmer. I'm a normal user.
So please, if it is possible, let me know how to make this software run on my PC.
Thanks.
Antonella.

_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users

_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users

0x99D28356FED78143.asc (3K) Download Attachment
signature.asc (235 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Linphone 4.2.3 starting issue on MacOs 10.12.6

Greg Troxel

Peio Rigaux <[hidden email]> writes:

> Could you please try to install the latest version of Linphone to see if
> your issue is fixed ? The 4.2.5 version
> <https://linphone.org/releases/macosx/app/> is available.

Note that at
  https://new.linphone.org/technical-corner/linphone?qt-technical_corner=2#qt-technical_corner
it is still offering 4.2.4 for download.

On an early 2011 MacBookPro running 10.13, I upgraded older Linphone
(4.2.1) to 4.2.4 and then 4.2.5.

On both, I got a warning about "downloaded from internet; open anyway?".

On both, I got a login failure on startup (I have two configured
accounts), but both accounts show logged in.

> If it still doesn't work, it might be related to your "old" device.

10.12 no longer gets security or others updates.  10.13 should be
available for your hardware, so if it were my box I would update it.

> I do not know how code signing works for Apple devices, so I think that
> I can't help you, but I can eventually ask my colleagues.

In macOS security settings, General, there is "allow apps from appstore
only, or appstore and identified devleopers".  I am pretty sure that
when I first installed linphone i had to click allow in that settings
for it.

I wonder what the target SDK level is for the build.  In macOS, one sets
an SDK level and then the binary will only use interfaces available in
that release, which are also provided by newer ones.  Picking 10.13
would be reasonable as older versions have had no security support for a
long time.  The other reasonable choice would be 10.11 as there is
working hardware stuck on 10.11.  In my view anything earlier than 10.11
is retrocomputing :-)   Looking with "otool -l", it seems to be 10.9
(which is fine as long as it doesn't hurt 10.13+ users).   So that's not
it.

So it works ok on 10.13.  (I'm pretty sure the login failure bug is a
separate issue.)


_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users

signature.asc (199 bytes) Download Attachment