Linphone version 4.0

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Linphone version 4.0

Hans-Peter Jansen
Hi Belledone Communications,

when reading your announcement about a new Qt based Linphone version, I was
very excited. Congratulations for this prospective decision!

I'm a big fan of Qt since the early v3 days (more specifically PyQt), and can
imagine the possibilities of your product on that basement, but also know, how
hard you must have worked because of the many missing pieces related to
telephony and video-phony protocols et.al..

Watching the accelerated spread of VoIP lately, and the more than suspecting
activities around Skype and related technologies, it's about the right time to
converge the new possibilities with traditional communication forms in an open
project, that targets all major platforms. Obviously, you must have
anticipated that a long time ago.

Having dived into Asterisk lately (again), I would like to build your package
on openSUSEs build service, where I maintain a "few" other packages already

        https://build.opensuse.org/project/subprojects/home:frispete

including linphone 3.11.1 in the telephony project. To the audience: if you're
missing a openSUSE distribution as build target, let me know. Other
distributions are (much) harder, but feasible, if there's an appropriate
demand...

To get my feeds wet, is there any git repo to clone Linphone version 4.0 from?

I cannot use flatpak on my primary system (openSUSE 13.2, don't ask ;),
because I didn't manage to get it built yet (glib and gtk issues).

>From a package maintainer perspective, Qt is much more convenient to support,
than the awful gtk can of worms (but you may have noticed, I'm biased). A
proper rpm package with proper dependencies is much preferred anyway...

Seeing your vision now (better late than never), I anticipate a huge demand of
your projects, and wish you and bright and promising future.

Warm regards,
Pete


_______________________________________________
Linphone-developers mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-developers
Reply | Threaded
Open this post in threaded view
|

Re: Linphone version 4.0

jehan.monnier
Hi Peter,

I’m very happy you like our new Linphone 4. Linphone team has worked very hard for more than a year to achieve this QT based UI :-).

With version 4 we are finishing our transition from automake/autoconf to a cmake build system. We still have a couple of spec file not ported yet, but I hope to finalize this transition soon.

Linphone 4 repository is available at: git clone <a href="git://git.linphone.org/linphone-desktop.git" class="">git://git.linphone.org/linphone-desktop.git —recursive

Let me know if your need anything else which can help you.

Best regards



Le 20 juin 2017 à 11:43, Hans-Peter Jansen <[hidden email]> a écrit :

Hi Belledone Communications,

when reading your announcement about a new Qt based Linphone version, I was
very excited. Congratulations for this prospective decision!

I'm a big fan of Qt since the early v3 days (more specifically PyQt), and can
imagine the possibilities of your product on that basement, but also know, how
hard you must have worked because of the many missing pieces related to
telephony and video-phony protocols et.al..

Watching the accelerated spread of VoIP lately, and the more than suspecting
activities around Skype and related technologies, it's about the right time to
converge the new possibilities with traditional communication forms in an open
project, that targets all major platforms. Obviously, you must have
anticipated that a long time ago.

Having dived into Asterisk lately (again), I would like to build your package
on openSUSEs build service, where I maintain a "few" other packages already

https://build.opensuse.org/project/subprojects/home:frispete

including linphone 3.11.1 in the telephony project. To the audience: if you're
missing a openSUSE distribution as build target, let me know. Other
distributions are (much) harder, but feasible, if there's an appropriate
demand...

To get my feeds wet, is there any git repo to clone Linphone version 4.0 from?

I cannot use flatpak on my primary system (openSUSE 13.2, don't ask ;),
because I didn't manage to get it built yet (glib and gtk issues).

From a package maintainer perspective, Qt is much more convenient to support,
than the awful gtk can of worms (but you may have noticed, I'm biased). A
proper rpm package with proper dependencies is much preferred anyway...

Seeing your vision now (better late than never), I anticipate a huge demand of
your projects, and wish you and bright and promising future.

Warm regards,
Pete


_______________________________________________
Linphone-developers mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-developers


_______________________________________________
Linphone-developers mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-developers