Monit sending the same email over and over again

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Monit sending the same email over and over again

daniel_1983
I received 50+ e-mails from monit for an http service I am monitoring. The first e-mail was sent at 23:00, with date Tue, 03 Jul 2018 23:00:33. Next mail was sent 15 minutes later, but w/ exact same date in the body. Then 15 minutes later, same date in the body. I checked more than a dozen of e-mails from the 50+ mails received, all with the same date in the body.

When I got to the office, I manually checked the http service by browsing to it. It was UP.

In the monit logs, I found that it might be that monit was resending the same e-mail over and over again :

[CET Jul  4 10:29:00] error    : Sendmail: error receiving data from the mailserver '10.10.10.19' -- Resource temporarily unavailable
[CET Jul  4 10:29:00] error    : Alert handler failed, retry scheduled for next cycle
[CET Jul  4 10:44:05] error    : Sendmail: error receiving data from the mailserver '10.10.10.19' -- Resource temporarily unavailable
[CET Jul  4 10:44:05] error    : Alert handler failed, retry scheduled for next cycle
[CET Jul  4 10:59:27] error    : Sendmail: error receiving data from the mailserver '10.10.10.19' -- Resource temporarily unavailable
[CET Jul  4 10:59:27] error    : Alert handler failed, retry scheduled for next cycle
[CET Jul  4 11:14:54] error    : Sendmail: error receiving data from the mailserver '10.10.10.19' -- Resource temporarily unavailable
[CET Jul  4 11:14:54] error    : Alert handler failed, retry scheduled for next cycle
[CET Jul  4 11:29:59] error    : Sendmail: error receiving data from the mailserver '10.10.10.19' -- Resource temporarily unavailable
[CET Jul  4 11:29:59] error    : Alert handler failed, retry scheduled for next cycle

So it appears that monit isn't receiving data from my mail server, although I AM receiving the mails from monit and I AM ABLE TO PING the mail server from the monit machine.

root@audio-mon[192.168.100.82] ~ # ping 10.10.10.19
PING 10.10.10.19 (10.10.10.19) 56(84) bytes of data.
64 bytes from 10.10.10.19: icmp_req=1 ttl=63 time=0.636 ms
64 bytes from 10.10.10.19: icmp_req=2 ttl=63 time=0.627 ms
^C
--- 10.10.10.19 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 999ms
rtt min/avg/max/mdev = 0.627/0.631/0.636/0.025 ms
root@audio-mon[192.168.100.82] ~ #


So how could 10.10.10.19 be unavailable to monit while it still can send mail through it ? how can I fix this ?




--
To unsubscribe:
https://lists.nongnu.org/mailman/listinfo/monit-general