Parallel Installation RPM for Python2 (rdiff-backup-1)

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Parallel Installation RPM for Python2 (rdiff-backup-1)

Frank Crawford
Folks,

I have made available a Python2 version of rdiff-backup 1.2.8 which can
be installed along with the current Python3 version of rdiff-backup for
currently supported Fedora and EPEL systems.

The package is named "python2-rdiff-backup" and installs the python
script "rdiff-backup-1".  It does not install additional executables,
or documentation, as these are supplied by the current version.

To run it just run "rdiff-backup-1" with the same arguments as the
current version of "rdiff-backup".

This should only be needed on a master backup server as all slaves
should only need a single version.

It can be installed with:

dnf copr enable frankcrawford/python2-rdiff-backup

or download the yum repo file from
https://copr.fedorainfracloud.org/coprs/frankcrawford/python2-rdiff-backup/

For EPEL-8 you will also have to download
https://copr.fedorainfracloud.org/coprs/frankcrawford/python2-pyxattr/
as it is not currently available in EPEL-8.

Note that I will not be offering any support for application issues
with this version, although I will look at packaging issue, if they are
found.

Regards
Frank


Reply | Threaded
Open this post in threaded view
|

Re: Parallel Installation RPM for Python2 (rdiff-backup-1)

Patrik Dufresne
Thanks again Frank for all your good work. Will probably help a lot of users

We should try to update the migration plans or readme document to reflect
this. To make sure it get more widely available.

On Sun., May 3, 2020, 8:36 a.m. Frank Crawford, <[hidden email]>
wrote:

> Folks,
>
> I have made available a Python2 version of rdiff-backup 1.2.8 which can
> be installed along with the current Python3 version of rdiff-backup for
> currently supported Fedora and EPEL systems.
>
> The package is named "python2-rdiff-backup" and installs the python
> script "rdiff-backup-1".  It does not install additional executables,
> or documentation, as these are supplied by the current version.
>
> To run it just run "rdiff-backup-1" with the same arguments as the
> current version of "rdiff-backup".
>
> This should only be needed on a master backup server as all slaves
> should only need a single version.
>
> It can be installed with:
>
> dnf copr enable frankcrawford/python2-rdiff-backup
>
> or download the yum repo file from
> https://copr.fedorainfracloud.org/coprs/frankcrawford/python2-rdiff-backup/
>
> For EPEL-8 you will also have to download
> https://copr.fedorainfracloud.org/coprs/frankcrawford/python2-pyxattr/
> as it is not currently available in EPEL-8.
>
> Note that I will not be offering any support for application issues
> with this version, although I will look at packaging issue, if they are
> found.
>
> Regards
> Frank
>
>
>