Problem loading librsync lib module

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem loading librsync lib module

duplicity-talk mailing list
Hello,
Im trying to instal duplicity on old OS. Must do manual install librsync
and old version of duplicity.
librsync is in /usr/local/lib
When run duplicity get this error:

File "/usr/local/lib/python2.7/dist-packages/duplicity/librsync.py",
line 30, in <module>
     from . import _librsync
ImportError: librsync.so.2: cannot open shared object file: No such file
or directory

I know its not right solution but I tried copy
/usr/local/lib/librsync.so  (NOT librsync.so.2) into the duplicity
install dir then I get this error:

File "/usr/local/lib/python2.7/dist-packages/duplicity/path.py", line
44, in <module>
     from duplicity import librsync
ImportError: dynamic module does not define init function (initlibrsync)

I also try go to duplicity source dir and execute compilec.py -- it's
successful build, so I copy _librsync.so into duplictiy install dir but
makes no difference.

Also tried install duplicity with
python setup.py install --librsync-dir=/usr/local/lib
But does not help

I know its old version but can i ask for some tip how i could face this
error? Thank you!

_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk
Reply | Threaded
Open this post in threaded view
|

Re: Problem loading librsync lib module

duplicity-talk mailing list
Hi MRob,

Where did you get this duplicity?  What version?

What OS are you using?  What version?

Normally, running setup.py from the root directory will do the trick.  Have you tried that?

...Thanks,
...Ken


On Wed, Jun 24, 2020 at 1:42 PM MRob via Duplicity-talk <[hidden email]> wrote:
Hello,
Im trying to instal duplicity on old OS. Must do manual install librsync
and old version of duplicity.
librsync is in /usr/local/lib
When run duplicity get this error:

File "/usr/local/lib/python2.7/dist-packages/duplicity/librsync.py",
line 30, in <module>
     from . import _librsync
ImportError: librsync.so.2: cannot open shared object file: No such file
or directory

I know its not right solution but I tried copy
/usr/local/lib/librsync.so  (NOT librsync.so.2) into the duplicity
install dir then I get this error:

File "/usr/local/lib/python2.7/dist-packages/duplicity/path.py", line
44, in <module>
     from duplicity import librsync
ImportError: dynamic module does not define init function (initlibrsync)

I also try go to duplicity source dir and execute compilec.py -- it's
successful build, so I copy _librsync.so into duplictiy install dir but
makes no difference.

Also tried install duplicity with
python setup.py install --librsync-dir=/usr/local/lib
But does not help

I know its old version but can i ask for some tip how i could face this
error? Thank you!

_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk

_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk
Reply | Threaded
Open this post in threaded view
|

Re: Problem loading librsync lib module

duplicity-talk mailing list
Hi Kenneth!

> Where did you get this duplicity?  What version?

 From github. 0.7.14 (need that version on purpose)

> What OS are you using?  What version?

Debian wheezy (yes i know)

> Normally, running setup.py from the root directory will do the trick.  
> Have
> you tried that?

Yes - downloaded tar.gz file, untarred, ran "python setup.py install" no
install errors, but the errors as below that i canot solve.

appreciate if you have suggestion. it's ok if its a hack because it will
only be temporary on a system that needs to be decommissioned


> On Wed, Jun 24, 2020 at 1:42 PM MRob via Duplicity-talk <
> [hidden email]> wrote:
>
>> Hello,
>> Im trying to instal duplicity on old OS. Must do manual install
>> librsync
>> and old version of duplicity.
>> librsync is in /usr/local/lib
>> When run duplicity get this error:
>>
>> File "/usr/local/lib/python2.7/dist-packages/duplicity/librsync.py",
>> line 30, in <module>
>>      from . import _librsync
>> ImportError: librsync.so.2: cannot open shared object file: No such
>> file
>> or directory
>>
>> I know its not right solution but I tried copy
>> /usr/local/lib/librsync.so  (NOT librsync.so.2) into the duplicity
>> install dir then I get this error:
>>
>> File "/usr/local/lib/python2.7/dist-packages/duplicity/path.py", line
>> 44, in <module>
>>      from duplicity import librsync
>> ImportError: dynamic module does not define init function
>> (initlibrsync)
>>
>> I also try go to duplicity source dir and execute compilec.py -- it's
>> successful build, so I copy _librsync.so into duplictiy install dir
>> but
>> makes no difference.
>>
>> Also tried install duplicity with
>> python setup.py install --librsync-dir=/usr/local/lib
>> But does not help
>>
>> I know its old version but can i ask for some tip how i could face
>> this
>> error? Thank you!
>>
>> _______________________________________________
>> Duplicity-talk mailing list
>> [hidden email]
>> https://lists.nongnu.org/mailman/listinfo/duplicity-talk
>>

_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk
Reply | Threaded
Open this post in threaded view
|

Re: Problem loading librsync lib module

duplicity-talk mailing list
Hi MRob,


Not sure what github repo you downloaded, so just playing it safe.

Also, please uninstall duplicity if it was previously installed via a repo.  They end up in different places and that can cause havoc.

You can find duplicity with:

$ find /usr -type f -name duplicity    # for the main
$ find /usr -type d -name duplicity   # for the library

Just remove them manually, especially if you find them in more than one location.  Then try the install from the tarball above.

...Ken


On Wed, Jun 24, 2020 at 4:11 PM MRob <[hidden email]> wrote:
Hi Kenneth!

> Where did you get this duplicity?  What version?

 From github. 0.7.14 (need that version on purpose)

> What OS are you using?  What version?

Debian wheezy (yes i know)

> Normally, running setup.py from the root directory will do the trick. 
> Have
> you tried that?

Yes - downloaded tar.gz file, untarred, ran "python setup.py install" no
install errors, but the errors as below that i canot solve.

appreciate if you have suggestion. it's ok if its a hack because it will
only be temporary on a system that needs to be decommissioned


> On Wed, Jun 24, 2020 at 1:42 PM MRob via Duplicity-talk <
> [hidden email]> wrote:
>
>> Hello,
>> Im trying to instal duplicity on old OS. Must do manual install
>> librsync
>> and old version of duplicity.
>> librsync is in /usr/local/lib
>> When run duplicity get this error:
>>
>> File "/usr/local/lib/python2.7/dist-packages/duplicity/librsync.py",
>> line 30, in <module>
>>      from . import _librsync
>> ImportError: librsync.so.2: cannot open shared object file: No such
>> file
>> or directory
>>
>> I know its not right solution but I tried copy
>> /usr/local/lib/librsync.so  (NOT librsync.so.2) into the duplicity
>> install dir then I get this error:
>>
>> File "/usr/local/lib/python2.7/dist-packages/duplicity/path.py", line
>> 44, in <module>
>>      from duplicity import librsync
>> ImportError: dynamic module does not define init function
>> (initlibrsync)
>>
>> I also try go to duplicity source dir and execute compilec.py -- it's
>> successful build, so I copy _librsync.so into duplictiy install dir
>> but
>> makes no difference.
>>
>> Also tried install duplicity with
>> python setup.py install --librsync-dir=/usr/local/lib
>> But does not help
>>
>> I know its old version but can i ask for some tip how i could face
>> this
>> error? Thank you!
>>
>> _______________________________________________
>> Duplicity-talk mailing list
>> [hidden email]
>> https://lists.nongnu.org/mailman/listinfo/duplicity-talk
>>

_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk
Reply | Threaded
Open this post in threaded view
|

Re: Problem loading librsync lib module

duplicity-talk mailing list
Hi Kenneth,

I'm sorry I was using launchpad-- i mistyped.
https://code.launchpad.net/duplicity/0.7-series/0.7.14/+download/duplicity-0.7.14.tar.gz

There is no other duplicity installed from repo and I also sure to use
--record to have a list of installed files to uninstal and try fresh
start.

Using your find cmd to dbl check i confirmed its clean:

$ find /usr -type f -name duplicity
/usr/local/bin/duplicity
/usr/local/src/duplicity/duplicity-0.7.14/bin/duplicity
/usr/local/src/duplicity/duplicity-0.7.14/build/scripts-2.7/duplicity

$ find /usr -type d -name duplicity
/usr/local/lib/python2.7/dist-packages/duplicity
/usr/local/src/duplicity
/usr/local/src/duplicity/duplicity-0.7.14/duplicity
/usr/local/src/duplicity/duplicity-0.7.14/build/temp.linux-x86_64-2.7/duplicity
/usr/local/src/duplicity/duplicity-0.7.14/build/lib.linux-x86_64-2.7/duplicity


Is there any quick hack to the code to find the librsync.so import
correctly?


> Please try the "official" source:
> https://launchpad.net/duplicity/0.7-series/0.7.14/+download/duplicity-0.7.14.tar.gz
>
> Not sure what github repo you downloaded, so just playing it safe.
>
> Also, please uninstall duplicity if it was previously installed via a
> repo.  They end up in different places and that can cause havoc.
>
> You can find duplicity with:
>
> $ find /usr -type f -name duplicity    # for the main
> $ find /usr -type d -name duplicity   # for the library
>
> Just remove them manually, especially if you find them in more than one
> location.  Then try the install from the tarball above.
>
> ...Ken
>
>
> On Wed, Jun 24, 2020 at 4:11 PM MRob <[hidden email]> wrote:
>
>> Hi Kenneth!
>>
>> > Where did you get this duplicity?  What version?
>>
>>  From github. 0.7.14 (need that version on purpose)
>>
>> > What OS are you using?  What version?
>>
>> Debian wheezy (yes i know)
>>
>> > Normally, running setup.py from the root directory will do the trick.
>> > Have
>> > you tried that?
>>
>> Yes - downloaded tar.gz file, untarred, ran "python setup.py install"
>> no
>> install errors, but the errors as below that i canot solve.
>>
>> appreciate if you have suggestion. it's ok if its a hack because it
>> will
>> only be temporary on a system that needs to be decommissioned
>>
>>
>> > On Wed, Jun 24, 2020 at 1:42 PM MRob via Duplicity-talk <
>> > [hidden email]> wrote:
>> >
>> >> Hello,
>> >> Im trying to instal duplicity on old OS. Must do manual install
>> >> librsync
>> >> and old version of duplicity.
>> >> librsync is in /usr/local/lib
>> >> When run duplicity get this error:
>> >>
>> >> File "/usr/local/lib/python2.7/dist-packages/duplicity/librsync.py",
>> >> line 30, in <module>
>> >>      from . import _librsync
>> >> ImportError: librsync.so.2: cannot open shared object file: No such
>> >> file
>> >> or directory
>> >>
>> >> I know its not right solution but I tried copy
>> >> /usr/local/lib/librsync.so  (NOT librsync.so.2) into the duplicity
>> >> install dir then I get this error:
>> >>
>> >> File "/usr/local/lib/python2.7/dist-packages/duplicity/path.py", line
>> >> 44, in <module>
>> >>      from duplicity import librsync
>> >> ImportError: dynamic module does not define init function
>> >> (initlibrsync)
>> >>
>> >> I also try go to duplicity source dir and execute compilec.py -- it's
>> >> successful build, so I copy _librsync.so into duplictiy install dir
>> >> but
>> >> makes no difference.
>> >>
>> >> Also tried install duplicity with
>> >> python setup.py install --librsync-dir=/usr/local/lib
>> >> But does not help
>> >>
>> >> I know its old version but can i ask for some tip how i could face
>> >> this
>> >> error? Thank you!
>> >>
>> >> _______________________________________________
>> >> Duplicity-talk mailing list
>> >> [hidden email]
>> >> https://lists.nongnu.org/mailman/listinfo/duplicity-talk
>> >>
>>

_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk
Reply | Threaded
Open this post in threaded view
|

Re: Problem loading librsync lib module

duplicity-talk mailing list
In reply to this post by duplicity-talk mailing list
On 24.06.2020 23:11, MRob via Duplicity-talk wrote:
>> Where did you get this duplicity?  What version?
>
> From github. 0.7.14 (need that version on purpose)

would you mind telling us the purpose? :9 ..ede/duply.net

_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk
Reply | Threaded
Open this post in threaded view
|

Re: Problem loading librsync lib module

duplicity-talk mailing list
In reply to this post by duplicity-talk mailing list
hey Mrob,

not sure what's failing in your case. but you may try as a tried and sureshot variant to install the way i install multiple versions in parallel to try and test them. essentially it's a self contained portable install with everything under one folder.

check "INSTALL MULTIPLE VERSIONS" on
http://duply.net/index.php?title=Documentation

good luck.. ede

On 25.06.2020 03:24, MRob via Duplicity-talk wrote:

> Hi Kenneth,
>
> I'm sorry I was using launchpad-- i mistyped.
> https://code.launchpad.net/duplicity/0.7-series/0.7.14/+download/duplicity-0.7.14.tar.gz
>
> There is no other duplicity installed from repo and I also sure to use --record to have a list of installed files to uninstal and try fresh start.
>
> Using your find cmd to dbl check i confirmed its clean:
>
> $ find /usr -type f -name duplicity
> /usr/local/bin/duplicity
> /usr/local/src/duplicity/duplicity-0.7.14/bin/duplicity
> /usr/local/src/duplicity/duplicity-0.7.14/build/scripts-2.7/duplicity
>
> $ find /usr -type d -name duplicity
> /usr/local/lib/python2.7/dist-packages/duplicity
> /usr/local/src/duplicity
> /usr/local/src/duplicity/duplicity-0.7.14/duplicity
> /usr/local/src/duplicity/duplicity-0.7.14/build/temp.linux-x86_64-2.7/duplicity
> /usr/local/src/duplicity/duplicity-0.7.14/build/lib.linux-x86_64-2.7/duplicity
>
>
> Is there any quick hack to the code to find the librsync.so import correctly?
>
>
>> Please try the "official" source:
>> https://launchpad.net/duplicity/0.7-series/0.7.14/+download/duplicity-0.7.14.tar.gz
>>
>> Not sure what github repo you downloaded, so just playing it safe.
>>
>> Also, please uninstall duplicity if it was previously installed via a
>> repo.  They end up in different places and that can cause havoc.
>>
>> You can find duplicity with:
>>
>> $ find /usr -type f -name duplicity    # for the main
>> $ find /usr -type d -name duplicity   # for the library
>>
>> Just remove them manually, especially if you find them in more than one
>> location.  Then try the install from the tarball above.
>>
>> ...Ken
>>
>>
>> On Wed, Jun 24, 2020 at 4:11 PM MRob <[hidden email]> wrote:
>>
>>> Hi Kenneth!
>>>
>>> > Where did you get this duplicity?  What version?
>>>
>>>  From github. 0.7.14 (need that version on purpose)
>>>
>>> > What OS are you using?  What version?
>>>
>>> Debian wheezy (yes i know)
>>>
>>> > Normally, running setup.py from the root directory will do the trick.
>>> > Have
>>> > you tried that?
>>>
>>> Yes - downloaded tar.gz file, untarred, ran "python setup.py install" no
>>> install errors, but the errors as below that i canot solve.
>>>
>>> appreciate if you have suggestion. it's ok if its a hack because it will
>>> only be temporary on a system that needs to be decommissioned
>>>
>>>
>>> > On Wed, Jun 24, 2020 at 1:42 PM MRob via Duplicity-talk <
>>> > [hidden email]> wrote:
>>> >
>>> >> Hello,
>>> >> Im trying to instal duplicity on old OS. Must do manual install
>>> >> librsync
>>> >> and old version of duplicity.
>>> >> librsync is in /usr/local/lib
>>> >> When run duplicity get this error:
>>> >>
>>> >> File "/usr/local/lib/python2.7/dist-packages/duplicity/librsync.py",
>>> >> line 30, in <module>
>>> >>      from . import _librsync
>>> >> ImportError: librsync.so.2: cannot open shared object file: No such
>>> >> file
>>> >> or directory
>>> >>
>>> >> I know its not right solution but I tried copy
>>> >> /usr/local/lib/librsync.so  (NOT librsync.so.2) into the duplicity
>>> >> install dir then I get this error:
>>> >>
>>> >> File "/usr/local/lib/python2.7/dist-packages/duplicity/path.py", line
>>> >> 44, in <module>
>>> >>      from duplicity import librsync
>>> >> ImportError: dynamic module does not define init function
>>> >> (initlibrsync)
>>> >>
>>> >> I also try go to duplicity source dir and execute compilec.py -- it's
>>> >> successful build, so I copy _librsync.so into duplictiy install dir
>>> >> but
>>> >> makes no difference.
>>> >>
>>> >> Also tried install duplicity with
>>> >> python setup.py install --librsync-dir=/usr/local/lib
>>> >> But does not help
>>> >>
>>> >> I know its old version but can i ask for some tip how i could face
>>> >> this
>>> >> error? Thank you!
>>> >>
>>> >> _______________________________________________
>>> >> Duplicity-talk mailing list
>>> >> [hidden email]
>>> >> https://lists.nongnu.org/mailman/listinfo/duplicity-talk
>>> >>
>>>
>
> _______________________________________________
> Duplicity-talk mailing list
> [hidden email]
> https://lists.nongnu.org/mailman/listinfo/duplicity-talk


_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk
Reply | Threaded
Open this post in threaded view
|

Re: Problem loading librsync lib module

duplicity-talk mailing list
In reply to this post by duplicity-talk mailing list
There is a fink package to install all the correct libraries under OS X.  I am updating that to Duplicity 8 and a newer python, but the current version should be working.  And a lot easier than manually installing things.

fink-project.org

-Scott


> On Jun 24, 2020, at 2:42 PM, MRob via Duplicity-talk <[hidden email]> wrote:
>
> Hello,
> Im trying to instal duplicity on old OS. Must do manual install librsync and old version of duplicity.
> librsync is in /usr/local/lib
> When run duplicity get this error:
>
> File "/usr/local/lib/python2.7/dist-packages/duplicity/librsync.py", line 30, in <module>
>    from . import _librsync
> ImportError: librsync.so.2: cannot open shared object file: No such file or directory
>
> I know its not right solution but I tried copy /usr/local/lib/librsync.so  (NOT librsync.so.2) into the duplicity install dir then I get this error:
>
> File "/usr/local/lib/python2.7/dist-packages/duplicity/path.py", line 44, in <module>
>    from duplicity import librsync
> ImportError: dynamic module does not define init function (initlibrsync)
>
> I also try go to duplicity source dir and execute compilec.py -- it's successful build, so I copy _librsync.so into duplictiy install dir but makes no difference.
>
> Also tried install duplicity with
> python setup.py install --librsync-dir=/usr/local/lib
> But does not help
>
> I know its old version but can i ask for some tip how i could face this error? Thank you!
>
> _______________________________________________
> Duplicity-talk mailing list
> [hidden email]
> https://lists.nongnu.org/mailman/listinfo/duplicity-talk


_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk
Reply | Threaded
Open this post in threaded view
|

Re: Problem loading librsync lib module

duplicity-talk mailing list
In reply to this post by duplicity-talk mailing list
Hi MRob,

Please run "sudo setup.py install >& setup.log", then attach the log file to the reply.

Don't confuse librsync.so with _librsync.so.  The first is the system library, the second is a Python interface to the library.

...Ken


On Thu, Jun 25, 2020 at 5:24 AM edgar.soldin--- via Duplicity-talk <[hidden email]> wrote:
hey Mrob,

not sure what's failing in your case. but you may try as a tried and sureshot variant to install the way i install multiple versions in parallel to try and test them. essentially it's a self contained portable install with everything under one folder.

check "INSTALL MULTIPLE VERSIONS" on
http://duply.net/index.php?title=Documentation

good luck.. ede

On 25.06.2020 03:24, MRob via Duplicity-talk wrote:
> Hi Kenneth,
>
> I'm sorry I was using launchpad-- i mistyped.
> https://code.launchpad.net/duplicity/0.7-series/0.7.14/+download/duplicity-0.7.14.tar.gz
>
> There is no other duplicity installed from repo and I also sure to use --record to have a list of installed files to uninstal and try fresh start.
>
> Using your find cmd to dbl check i confirmed its clean:
>
> $ find /usr -type f -name duplicity
> /usr/local/bin/duplicity
> /usr/local/src/duplicity/duplicity-0.7.14/bin/duplicity
> /usr/local/src/duplicity/duplicity-0.7.14/build/scripts-2.7/duplicity
>
> $ find /usr -type d -name duplicity
> /usr/local/lib/python2.7/dist-packages/duplicity
> /usr/local/src/duplicity
> /usr/local/src/duplicity/duplicity-0.7.14/duplicity
> /usr/local/src/duplicity/duplicity-0.7.14/build/temp.linux-x86_64-2.7/duplicity
> /usr/local/src/duplicity/duplicity-0.7.14/build/lib.linux-x86_64-2.7/duplicity
>
>
> Is there any quick hack to the code to find the librsync.so import correctly?
>
>
>> Please try the "official" source:
>> https://launchpad.net/duplicity/0.7-series/0.7.14/+download/duplicity-0.7.14.tar.gz
>>
>> Not sure what github repo you downloaded, so just playing it safe.
>>
>> Also, please uninstall duplicity if it was previously installed via a
>> repo.  They end up in different places and that can cause havoc.
>>
>> You can find duplicity with:
>>
>> $ find /usr -type f -name duplicity    # for the main
>> $ find /usr -type d -name duplicity   # for the library
>>
>> Just remove them manually, especially if you find them in more than one
>> location.  Then try the install from the tarball above.
>>
>> ...Ken
>>
>>
>> On Wed, Jun 24, 2020 at 4:11 PM MRob <[hidden email]> wrote:
>>
>>> Hi Kenneth!
>>>
>>> > Where did you get this duplicity?  What version?
>>>
>>>  From github. 0.7.14 (need that version on purpose)
>>>
>>> > What OS are you using?  What version?
>>>
>>> Debian wheezy (yes i know)
>>>
>>> > Normally, running setup.py from the root directory will do the trick.
>>> > Have
>>> > you tried that?
>>>
>>> Yes - downloaded tar.gz file, untarred, ran "python setup.py install" no
>>> install errors, but the errors as below that i canot solve.
>>>
>>> appreciate if you have suggestion. it's ok if its a hack because it will
>>> only be temporary on a system that needs to be decommissioned
>>>
>>>
>>> > On Wed, Jun 24, 2020 at 1:42 PM MRob via Duplicity-talk <
>>> > [hidden email]> wrote:
>>> >
>>> >> Hello,
>>> >> Im trying to instal duplicity on old OS. Must do manual install
>>> >> librsync
>>> >> and old version of duplicity.
>>> >> librsync is in /usr/local/lib
>>> >> When run duplicity get this error:
>>> >>
>>> >> File "/usr/local/lib/python2.7/dist-packages/duplicity/librsync.py",
>>> >> line 30, in <module>
>>> >>      from . import _librsync
>>> >> ImportError: librsync.so.2: cannot open shared object file: No such
>>> >> file
>>> >> or directory
>>> >>
>>> >> I know its not right solution but I tried copy
>>> >> /usr/local/lib/librsync.so  (NOT librsync.so.2) into the duplicity
>>> >> install dir then I get this error:
>>> >>
>>> >> File "/usr/local/lib/python2.7/dist-packages/duplicity/path.py", line
>>> >> 44, in <module>
>>> >>      from duplicity import librsync
>>> >> ImportError: dynamic module does not define init function
>>> >> (initlibrsync)
>>> >>
>>> >> I also try go to duplicity source dir and execute compilec.py -- it's
>>> >> successful build, so I copy _librsync.so into duplictiy install dir
>>> >> but
>>> >> makes no difference.
>>> >>
>>> >> Also tried install duplicity with
>>> >> python setup.py install --librsync-dir=/usr/local/lib
>>> >> But does not help
>>> >>
>>> >> I know its old version but can i ask for some tip how i could face
>>> >> this
>>> >> error? Thank you!
>>> >>
>>> >> _______________________________________________
>>> >> Duplicity-talk mailing list
>>> >> [hidden email]
>>> >> https://lists.nongnu.org/mailman/listinfo/duplicity-talk
>>> >>
>>>
>
> _______________________________________________
> Duplicity-talk mailing list
> [hidden email]
> https://lists.nongnu.org/mailman/listinfo/duplicity-talk


_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk

_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk