Problem with microphone - no input

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem with microphone - no input

Zbigniew Baniewski
It seems, that Linphone does not take any sound from my SB-Live. I've found
an old message with explanation:

"The problem is certainly that your driver does not like non-blocking mode
(the mode used by linphone, but not by other softphones.).
Upgrading to alsa drivers will solve the problem."

(Mon, 08 Dec 2003 17:49:22 +0100, Re: [Linphone-users] One way sound on
RedHat 9, SB Live + feature requests)

But I really wouldn't to make any mess in the system - OSS is working just
fine, and I wouldn't to switch to ALSA. Does there exist any other way to
persuade Linphone to make use out of the microphone?
--
                                pozdrawiam / regards

                                                Zbigniew Baniewski


_______________________________________________
Linphone-users mailing list
[hidden email]
http://lists.nongnu.org/mailman/listinfo/linphone-users
Reply | Threaded
Open this post in threaded view
|

Re: Problem with microphone - no input

Simon Morlat
Le Vendredi 4 Novembre 2005 01:53, Zbigniew Baniewski a écrit :

> It seems, that Linphone does not take any sound from my SB-Live. I've found
> an old message with explanation:
>
> "The problem is certainly that your driver does not like non-blocking mode
> (the mode used by linphone, but not by other softphones.).
> Upgrading to alsa drivers will solve the problem."
>
> (Mon, 08 Dec 2003 17:49:22 +0100, Re: [Linphone-users] One way sound on
> RedHat 9, SB Live + feature requests)
>
> But I really wouldn't to make any mess in the system - OSS is working just
> fine, and I wouldn't to switch to ALSA. Does there exist any other way to
> persuade Linphone to make use out of the microphone?

The problem is to try to persuade the oss driver to return back some samples
to linphone... I found no easy way to do that. Linphone opens the audio
device in full duplex and does non blocking read/writes, it seems some oss
drivers show bugs when operating under this mode.

Simon


_______________________________________________
Linphone-users mailing list
[hidden email]
http://lists.nongnu.org/mailman/listinfo/linphone-users