Problem with onedrive (python-requests)

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem with onedrive (python-requests)

duplicity-talk mailing list
Hi,

currently I'm trying to set up duplicity to backup my files to OneDrive but I get the error:

BackendException: OneDrive backend requires python-requests and python-requests-oauthlib to be installed. Please install them and try again.

I checked and both packages are installed:

pip install requests requests_oauthlib
Requirement already satisfied: requests in /usr/lib/python3.6/site-packages
Requirement already satisfied: requests_oauthlib in /usr/lib/python3.6/site-packages
Requirement already satisfied: oauthlib>=0.6.2 in /usr/lib/python3.6/site-packages (from requests_oauthlib)


Do I have to perform additional steps? The error output says that I just need to install the packages.

Thanks!

Thomas

_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk
Reply | Threaded
Open this post in threaded view
|

Re: Problem with onedrive (python-requests)

duplicity-talk mailing list
On 21.02.2017 21:57, Thomas via Duplicity-talk wrote:

> Hi,
>
> currently I'm trying to set up duplicity to backup my files to OneDrive but I get the error:
>
> BackendException: OneDrive backend requires python-requests and python-requests-oauthlib to be installed. Please install them and try again.
>
> I checked and both packages are installed:
>
> pip install requests requests_oauthlib
> Requirement already satisfied: requests in /usr/lib/python3.6/site-packages
> Requirement already satisfied: requests_oauthlib in /usr/lib/python3.6/site-packages
> Requirement already satisfied: oauthlib>=0.6.2 in /usr/lib/python3.6/site-packages (from requests_oauthlib)
>
>
> Do I have to perform additional steps? The error output says that I just need to install the packages.
>

duplicity is using python2 not python3.. install the modules for python2 and you are set.. ede/duply.net

_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk
Reply | Threaded
Open this post in threaded view
|

Re: Problem with onedrive (python-requests)

duplicity-talk mailing list
Thank you, the backup runs fine now.


> "edgar.soldin--- via Duplicity-talk" <[hidden email]> hat am 21. Februar 2017 um 22:21 geschrieben:
>
>
> On 21.02.2017 21:57, Thomas via Duplicity-talk wrote:
> > Hi,
> >
> > currently I'm trying to set up duplicity to backup my files to OneDrive but I get the error:
> >
> > BackendException: OneDrive backend requires python-requests and python-requests-oauthlib to be installed. Please install them and try again.
> >
> > I checked and both packages are installed:
> >
> > pip install requests requests_oauthlib
> > Requirement already satisfied: requests in /usr/lib/python3.6/site-packages
> > Requirement already satisfied: requests_oauthlib in /usr/lib/python3.6/site-packages
> > Requirement already satisfied: oauthlib>=0.6.2 in /usr/lib/python3.6/site-packages (from requests_oauthlib)
> >
> >
> > Do I have to perform additional steps? The error output says that I just need to install the packages.
> >
>
> duplicity is using python2 not python3.. install the modules for python2 and you are set.. ede/duply.net
>
> _______________________________________________
> Duplicity-talk mailing list
> [hidden email]
> https://lists.nongnu.org/mailman/listinfo/duplicity-talk

_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk