Problems building sks

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problems building sks

Jan Kesten-6
Hello together!

I just tried to get my sks up and running again. I could not get
Peters debian-sks package to work, ist does not compile on my Debian
sarge system on amd64.

I tried the following:

Got debian-sks from subversion - doesn't compile because of the new numerix.

Got sks mainline vrom bzr and tar'ed it to sks-1.0.10.debian.tar.gz
and put it into debian-sks, modified one patch for Dlong/Slong. But
does not compile either:

bdb/libbdb.a(bdb_stubs.o): In function `caml_cursor_dup':
bdb_stubs.c:(.text+0x144b): undefined reference to `db_strerror_4002'
bdb/libbdb.a(bdb_stubs.o): In function `caml_cursor_count':
bdb_stubs.c:(.text+0x14f8): undefined reference to `db_strerror_4002'
bdb/libbdb.a(bdb_stubs.o): In function `caml_cursor_del':

Tried to compile sks directly from mainline, failed at:

File "int_comparators.ml", line 4, characters 8-9:
Lexing error: character '<' expected
Uncaught exception: Token.Error("character '<' expected")
Preprocessing error
make: *** [dep] Error 2

Installed ocaml version:

ifjke@debian3164m:~/sks-1.0.10$ ocaml
        Objective Caml version 3.09.2

Anyone got sks running on a amd64 machine with sarge?

Thanks for any hints,
Jan


_______________________________________________
Sks-devel mailing list
[hidden email]
http://lists.nongnu.org/mailman/listinfo/sks-devel