Re: {Linphone-users] Registration to public server no longer working?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: {Linphone-users] Registration to public server no longer working?

caj_lists
On 26 Dec 2019 4:07:36AM Joel Black <address@hidden> wrote:
> We just recently created accounts and it still works for us.

@JoelBlack, thank you for that. Might I ask what client(s)/platforms you
are using?

On 25 Dec 2019 7:46:16AM Greg Troxel <address@hidden> wrote:
> In some of the previous problems, the issues seem to relate to the
> service having SRV records to point to unusual ports (vs UDP 5060,
> TCP 5060 and TCP 5061)
@GregTroxel - Looks like I will have to do some digging into logfiles to
see what ports it actually tried to use, or perhaps just try entering
those other odd ports along with the server names...

> You say you are using CSipSimple, but my impression is that
> CSipSimple is really unmaintained. When was the last release?

Yes, it is pretty much abandonware; it is removed from both the
playstore and F-Droid main repo, and the repository on Google Code is no
more. I think the code was last updated on 30Nov2014 and then put up on
F-Droid on 21Feb2015. Now there just seems to be a few f-droid builds in
Izzy's archive repo, a code dump of sorts plus (obsolete) issues list on
Github, plus whatever was snagged by Wayback crawls before Google Code
vanished. There's not much surviving documentation, mostly on Wayback
which is probably not complete though a few wiki items are there.

> If the documentation is not clear, you might file a bug asking for a
> doc clarification on whether or not the SRV scheme is supported.

The stuff from Google Code is gone. Given that it is abandonware I don't
expect a response at Github. I did find some changelog stuff mentioning
DNS SRV support being added at version 0.00-14 which is so old I can't
find the source, but must be before 0.02-02 dated 16Sep2012 (the oldest
source in the Wayback crawls). I do see a checkbox in the app settings
for this, which I have marked so I hope it is suitable. I probably need
to check logfiles to see what it did.

However, it DID used to register even at Linphone, so either this
feature works, or else it just wasn't needed at all until recently?
Also, it continues to register with other services, just not Linphone.
This is problematic since the other services don't handle texting, which
is what I used the Linphone service for.

> If CSipSimple is unmaintained, then I don't understand a decision to
> use it.

That one's easy - at the time I installed it, it was the ONLY (open OR
closed source) client I could find that was compatible with older
devices, and could handle SIP addresses rather than only phone numbers.
Granted one of the three devices is currently running Pie (formerly
Nougat and then Oreo) so it has more options, but the other two do not -
one runs FroYo, the other IceCreamSandwich, with no further upgrades
possible.

> You might try the linphone app or baresip-studio:
>   https://github.com/juha-h/baresip-studio/
> baresip-studio is in f-droid.

These might work for the newest device but not for the older ones.
Linphone requires at least JellyBean and baresip needs at least
Lollipop. With CSipSimple I used to be able to run the same client for
all 3 devices, which reduced user confusion.

_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users