Re: [Monotone-users] I'm sorry to keep bothering you

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: [Monotone-users] I'm sorry to keep bothering you

Stephen Leake-3
jfl <[hidden email]> writes:

> mkdir ~/mtn/ooncd ; cd ~/mtn/ooncd
> mtn db init --db=ooncd
> mtn --db=ooncd --branch=th.or.ooncd-th setup th
> cd th
> cp -r ../../ooncd-old/th/rst .
> cp ../../ooncd-old/th/makefile .
> mtn add -R rst makefile
> mtn commit -kjfl-transport@mail.i2p --message="initial checkin of ooncd-th"
> cd ..
> ...
> mtn pull mtn://127.0.0.1:8990/ooncd
> mtn: misuse: no database specified
>
> +++
>
> I don't understand why the branch is empty, or why I even need a key
> to run the clone command ...

I don't see where you tried to run "clone".

> So, I tried pull ... but monotone doesn't know what I'm talking about.

The error message is almost clear; you did not tell mtn what database to
pull _to_; you only told it what database to pull _from_.

_if_ mtn is run in a workspace, it uses the defaults specified in
_MTN/options. But your 'pull' command is not in a workspace; it is in
~/mtn/ooncd, the workspace is in ~/mtn/ooncd/th

So you need:

mtn -d ~/mtn/ooncd/ooncd pull mtn://127.0.0.1:8990/ooncd

or:

cd th
mtn pull mtn://127.0.0.1:8990/ooncd

> Why does 'k' take just one dash, no space, and the keyname in some
> commands and the 'normal' two dashes, '=', and the keyname in quotes
> in others?

You can always use either; '-k<name>' is short for '--key=<name>'.

--
-- Stephe

_______________________________________________
Monotone-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/monotone-devel