SIP Registration rejecting username/password with 401

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

SIP Registration rejecting username/password with 401

El Pato
I have 2 PJSIP clients that worked fine for months.  They both started failing auth on August 28 around 1:30 in the morning Pacific Daylight Time.

My logs captured the event:

2019-08-28:2019-08-29,01:34:02.457 WARNING MainThread account.onRegState 0 171100 401 [hidden email] Unauthorized

2019-08-28:2019-08-29,01:25:57.602 WARNING MainThread onRegState 0 171100 Unauthorized 401

After this event, every subsequent registration fails with "server rejected with stale=false".  This has been going on for over 2 days now.

PJSIP Status 171100 = PJSIP_EFAILEDCREDENTIAL.

The docs for PJSIP_EFAILEDCREDENTIAL say
"Credential failed to authenticate. For this failure, right credential for the realm has been found and used to authenticate against the challenge, but the server has rejected the authorization request with 401/407 response (either with no stale parameter or with "stale=false" parameter). In most cases, this indicates that the username/password combination is incorrect. "

Something is broken with the linphone sip server, it is rejecting valid username/password combinations.


_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users
Reply | Threaded
Open this post in threaded view
|

Re: SIP Registration rejecting username/password with 401

Echedey López Romero
It is strange, this issues only happen on desktop client for some people here. No problem on mobile client.

If its related with the FlexiSIP server from Linphone free SIP service I would prefer wait on a report in the desktop client repo for devs confirmation if its is an issue from server side or client side. It is true that maybe they changed something in the server but that could be a "good change" that mobile clients from them already supported and they must update the desktop client now.

Regards,
Echedey, López RomeroEl 30 ago. 2019 19:25, El Pato <[hidden email]> escribió:

>
> I have 2 PJSIP clients that worked fine for months.  They both started failing auth on August 28 around 1:30 in the morning Pacific Daylight Time.
>
> My logs captured the event:
>
> 2019-08-28:2019-08-29,01:34:02.457 WARNING MainThread account.onRegState 0 171100 401 sip:[hidden email] Unauthorized
>
> 2019-08-28:2019-08-29,01:25:57.602 WARNING MainThread onRegState 0 171100 Unauthorized 401
>
> After this event, every subsequent registration fails with "server rejected with stale=false".  This has been going on for over 2 days now.
>
> PJSIP Status 171100 = PJSIP_EFAILEDCREDENTIAL.
>
> The docs for PJSIP_EFAILEDCREDENTIAL say
> "Credential failed to authenticate. For this failure, right credential for the realm has been found and used to authenticate against the challenge, but the server has rejected the authorization request with 401/407 response (either with no stale parameter or with "stale=false" parameter). In most cases, this indicates that the username/password combination is incorrect. "
>
> Something is broken with the linphone sip server, it is rejecting valid username/password combinations.
>
_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users
Reply | Threaded
Open this post in threaded view
|

Re: SIP Registration rejecting username/password with 401

Russell Treleaven
Latest client on osx is working fine with my own sip server.

On Fri, Aug 30, 2019, 2:45 PM Echedey López Romero <[hidden email]> wrote:
It is strange, this issues only happen on desktop client for some people here. No problem on mobile client.

If its related with the FlexiSIP server from Linphone free SIP service I would prefer wait on a report in the desktop client repo for devs confirmation if its is an issue from server side or client side. It is true that maybe they changed something in the server but that could be a "good change" that mobile clients from them already supported and they must update the desktop client now.

Regards,
Echedey, López RomeroEl 30 ago. 2019 19:25, El Pato <[hidden email]> escribió:
>
> I have 2 PJSIP clients that worked fine for months.  They both started failing auth on August 28 around 1:30 in the morning Pacific Daylight Time.
>
> My logs captured the event:
>
> 2019-08-28:2019-08-29,01:34:02.457 WARNING MainThread account.onRegState 0 171100 401 [hidden email] Unauthorized
>
> 2019-08-28:2019-08-29,01:25:57.602 WARNING MainThread onRegState 0 171100 Unauthorized 401
>
> After this event, every subsequent registration fails with "server rejected with stale=false".  This has been going on for over 2 days now.
>
> PJSIP Status 171100 = PJSIP_EFAILEDCREDENTIAL.
>
> The docs for PJSIP_EFAILEDCREDENTIAL say
> "Credential failed to authenticate. For this failure, right credential for the realm has been found and used to authenticate against the challenge, but the server has rejected the authorization request with 401/407 response (either with no stale parameter or with "stale=false" parameter). In most cases, this indicates that the username/password combination is incorrect. "
>
> Something is broken with the linphone sip server, it is rejecting valid username/password combinations.
>
_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users

_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users
Reply | Threaded
Open this post in threaded view
|

Re: SIP Registration rejecting username/password with 401

Echedey López Romero
Are you using the last version of FlexiSIP server and 4.1.1 version of the desktop client?

Could you test that client with an account on the Linphone SIP service?

I attached my log trying registration on the main service.

30 de agosto de 2019 19:52, "Russell Treleaven" <[hidden email]> escribió:
Latest client on osx is working fine with my own sip server.
On Fri, Aug 30, 2019, 2:45 PM Echedey López Romero <[hidden email]> wrote:
It is strange, this issues only happen on desktop client for some people here. No problem on mobile client.

If its related with the FlexiSIP server from Linphone free SIP service I would prefer wait on a report in the desktop client repo for devs confirmation if its is an issue from server side or client side. It is true that maybe they changed something in the server but that could be a "good change" that mobile clients from them already supported and they must update the desktop client now.

Regards,
Echedey, López RomeroEl 30 ago. 2019 19:25, El Pato <[hidden email]> escribió:

>
> I have 2 PJSIP clients that worked fine for months. They both started failing auth on August 28 around 1:30 in the morning Pacific Daylight Time.
>
> My logs captured the event:
>
> 2019-08-28:2019-08-29,01:34:02.457 WARNING MainThread account.onRegState 0 171100 401 [hidden email] Unauthorized
>
> 2019-08-28:2019-08-29,01:25:57.602 WARNING MainThread onRegState 0 171100 Unauthorized 401
>
> After this event, every subsequent registration fails with "server rejected with stale=false". This has been going on for over 2 days now.
>
> PJSIP Status 171100 = PJSIP_EFAILEDCREDENTIAL.
>
> The docs for PJSIP_EFAILEDCREDENTIAL say
> "Credential failed to authenticate. For this failure, right credential for the realm has been found and used to authenticate against the challenge, but the server has rejected the authorization request with 401/407 response (either with no stale parameter or with "stale=false" parameter). In most cases, this indicates that the username/password combination is incorrect. "
>
> Something is broken with the linphone sip server, it is rejecting valid username/password combinations.
>
_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users


--
Regards,
Echedey, López Romero

_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users

linphone.log (8K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: SIP Registration rejecting username/password with 401

Russell Treleaven
I am using Linphone Desktop 4.1.1 - Qt5.9.0 on OSX.
Server side is not Flexisip though.
I think I have a sip.linphone.org account already set up on another machine.
Will try to test later today.

On Fri, Aug 30, 2019 at 2:59 PM Echedey <[hidden email]> wrote:
Are you using the last version of FlexiSIP server and 4.1.1 version of the desktop client?

Could you test that client with an account on the Linphone SIP service?

I attached my log trying registration on the main service.

30 de agosto de 2019 19:52, "Russell Treleaven" <[hidden email]> escribió:
Latest client on osx is working fine with my own sip server.
On Fri, Aug 30, 2019, 2:45 PM Echedey López Romero <[hidden email]> wrote:
It is strange, this issues only happen on desktop client for some people here. No problem on mobile client.

If its related with the FlexiSIP server from Linphone free SIP service I would prefer wait on a report in the desktop client repo for devs confirmation if its is an issue from server side or client side. It is true that maybe they changed something in the server but that could be a "good change" that mobile clients from them already supported and they must update the desktop client now.

Regards,
Echedey, López RomeroEl 30 ago. 2019 19:25, El Pato <[hidden email]> escribió:

>
> I have 2 PJSIP clients that worked fine for months. They both started failing auth on August 28 around 1:30 in the morning Pacific Daylight Time.
>
> My logs captured the event:
>
> 2019-08-28:2019-08-29,01:34:02.457 WARNING MainThread account.onRegState 0 171100 401 [hidden email] Unauthorized
>
> 2019-08-28:2019-08-29,01:25:57.602 WARNING MainThread onRegState 0 171100 Unauthorized 401
>
> After this event, every subsequent registration fails with "server rejected with stale=false". This has been going on for over 2 days now.
>
> PJSIP Status 171100 = PJSIP_EFAILEDCREDENTIAL.
>
> The docs for PJSIP_EFAILEDCREDENTIAL say
> "Credential failed to authenticate. For this failure, right credential for the realm has been found and used to authenticate against the challenge, but the server has rejected the authorization request with 401/407 response (either with no stale parameter or with "stale=false" parameter). In most cases, this indicates that the username/password combination is incorrect. "
>
> Something is broken with the linphone sip server, it is rejecting valid username/password combinations.
>
_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users


--
Regards,
Echedey, López Romero
_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users


--
Sincerely,

Russell Treleaven
[hidden email];transport=tcp


_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users
Reply | Threaded
Open this post in threaded view
|

Re: SIP Registration rejecting username/password with 401

Russell Treleaven
In reply to this post by Echedey López Romero
You are getting SIP/2.0 403 Forbidden response.

On Fri, Aug 30, 2019 at 2:59 PM Echedey <[hidden email]> wrote:
Are you using the last version of FlexiSIP server and 4.1.1 version of the desktop client?

Could you test that client with an account on the Linphone SIP service?

I attached my log trying registration on the main service.

30 de agosto de 2019 19:52, "Russell Treleaven" <[hidden email]> escribió:
Latest client on osx is working fine with my own sip server.
On Fri, Aug 30, 2019, 2:45 PM Echedey López Romero <[hidden email]> wrote:
It is strange, this issues only happen on desktop client for some people here. No problem on mobile client.

If its related with the FlexiSIP server from Linphone free SIP service I would prefer wait on a report in the desktop client repo for devs confirmation if its is an issue from server side or client side. It is true that maybe they changed something in the server but that could be a "good change" that mobile clients from them already supported and they must update the desktop client now.

Regards,
Echedey, López RomeroEl 30 ago. 2019 19:25, El Pato <[hidden email]> escribió:

>
> I have 2 PJSIP clients that worked fine for months. They both started failing auth on August 28 around 1:30 in the morning Pacific Daylight Time.
>
> My logs captured the event:
>
> 2019-08-28:2019-08-29,01:34:02.457 WARNING MainThread account.onRegState 0 171100 401 [hidden email] Unauthorized
>
> 2019-08-28:2019-08-29,01:25:57.602 WARNING MainThread onRegState 0 171100 Unauthorized 401
>
> After this event, every subsequent registration fails with "server rejected with stale=false". This has been going on for over 2 days now.
>
> PJSIP Status 171100 = PJSIP_EFAILEDCREDENTIAL.
>
> The docs for PJSIP_EFAILEDCREDENTIAL say
> "Credential failed to authenticate. For this failure, right credential for the realm has been found and used to authenticate against the challenge, but the server has rejected the authorization request with 401/407 response (either with no stale parameter or with "stale=false" parameter). In most cases, this indicates that the username/password combination is incorrect. "
>
> Something is broken with the linphone sip server, it is rejecting valid username/password combinations.
>
_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users


--
Regards,
Echedey, López Romero
_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users


--
Sincerely,

Russell Treleaven
[hidden email];transport=tcp


_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users
Reply | Threaded
Open this post in threaded view
|

Re: SIP Registration rejecting username/password with 401

Russell Treleaven
sip.linphone.org is not working here for my latest desktop version on OSX.
sipsak shows a 404 error, seems the server doesn't recognize my username
sigh :|

On Fri, Aug 30, 2019 at 3:57 PM Russell Treleaven <[hidden email]> wrote:
You are getting SIP/2.0 403 Forbidden response.

On Fri, Aug 30, 2019 at 2:59 PM Echedey <[hidden email]> wrote:
Are you using the last version of FlexiSIP server and 4.1.1 version of the desktop client?

Could you test that client with an account on the Linphone SIP service?

I attached my log trying registration on the main service.

30 de agosto de 2019 19:52, "Russell Treleaven" <[hidden email]> escribió:
Latest client on osx is working fine with my own sip server.
On Fri, Aug 30, 2019, 2:45 PM Echedey López Romero <[hidden email]> wrote:
It is strange, this issues only happen on desktop client for some people here. No problem on mobile client.

If its related with the FlexiSIP server from Linphone free SIP service I would prefer wait on a report in the desktop client repo for devs confirmation if its is an issue from server side or client side. It is true that maybe they changed something in the server but that could be a "good change" that mobile clients from them already supported and they must update the desktop client now.

Regards,
Echedey, López RomeroEl 30 ago. 2019 19:25, El Pato <[hidden email]> escribió:

>
> I have 2 PJSIP clients that worked fine for months. They both started failing auth on August 28 around 1:30 in the morning Pacific Daylight Time.
>
> My logs captured the event:
>
> 2019-08-28:2019-08-29,01:34:02.457 WARNING MainThread account.onRegState 0 171100 401 [hidden email] Unauthorized
>
> 2019-08-28:2019-08-29,01:25:57.602 WARNING MainThread onRegState 0 171100 Unauthorized 401
>
> After this event, every subsequent registration fails with "server rejected with stale=false". This has been going on for over 2 days now.
>
> PJSIP Status 171100 = PJSIP_EFAILEDCREDENTIAL.
>
> The docs for PJSIP_EFAILEDCREDENTIAL say
> "Credential failed to authenticate. For this failure, right credential for the realm has been found and used to authenticate against the challenge, but the server has rejected the authorization request with 401/407 response (either with no stale parameter or with "stale=false" parameter). In most cases, this indicates that the username/password combination is incorrect. "
>
> Something is broken with the linphone sip server, it is rejecting valid username/password combinations.
>
_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users


--
Regards,
Echedey, López Romero
_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users


--
Sincerely,

Russell Treleaven
[hidden email];transport=tcp



--
Sincerely,

Russell Treleaven
[hidden email];transport=tcp


_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users
Reply | Threaded
Open this post in threaded view
|

Re: SIP Registration rejecting username/password with 401

Stuart D. Gathman
I tried some things, and found that user names with only lowercase
letters work fine with sip.linphone.org, but it doesn't recognize user
names with a '.', like [hidden email].  Any reason not
to share real usernames on this list?  Will we get spammed on linphone?

On Fri, 30 Aug 2019, Russell Treleaven wrote:

> sip.linphone.org is not working here for my latest desktop version on
> OSX.sipsak shows a 404 error, seems the server doesn't recognize my username
> sigh :|
>
> On Fri, Aug 30, 2019 at 3:57 PM Russell Treleaven <[hidden email]>
> wrote:
>       You are getting SIP/2.0 403 Forbidden response.

--
       Stuart D. Gathman <[hidden email]>
"Confutatis maledictis, flamis acribus addictis" - background song for
a Microsoft sponsored "Where do you want to go from here?" commercial.
_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users
Reply | Threaded
Open this post in threaded view
|

Re: SIP Registration rejecting username/password with 401

Echedey López Romero
In reply to this post by El Pato
I shared mine on the log some hours ago. echedeylr is my username there.

Regards,
Echedey, López RomeroEl 31 ago. 2019 3:57 a. m., "Stuart D. Gathman" <[hidden email]> escribió:

>
> I tried some things, and found that user names with only lowercase
> letters work fine with sip.linphone.org, but it doesn't recognize user
> names with a '.', like [hidden email].  Any reason not
> to share real usernames on this list?  Will we get spammed on linphone?
>
> On Fri, 30 Aug 2019, Russell Treleaven wrote:
>
> > sip.linphone.org is not working here for my latest desktop version on
> > OSX.sipsak shows a 404 error, seems the server doesn't recognize my username
> > sigh :|
> >
> > On Fri, Aug 30, 2019 at 3:57 PM Russell Treleaven <[hidden email]>
> > wrote:
> >       You are getting SIP/2.0 403 Forbidden response.
>
> --
>       Stuart D. Gathman <[hidden email]>
> "Confutatis maledictis, flamis acribus addictis" - background song for
> a Microsoft sponsored "Where do you want to go from here?" commercial.
> _______________________________________________
> Linphone-users mailing list
> [hidden email]
> https://lists.nongnu.org/mailman/listinfo/linphone-users
_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users
Reply | Threaded
Open this post in threaded view
|

Re: SIP Registration rejecting username/password with 401

ael-2
In reply to this post by Stuart D. Gathman
On Fri, Aug 30, 2019 at 10:57:35PM -0400, Stuart D. Gathman wrote:
> I tried some things, and found that user names with only lowercase
> letters work fine with sip.linphone.org, but it doesn't recognize user
> names with a '.', like [hidden email].  Any reason not

My username does not include any ".". But I still see the problem.

ael


_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users
Reply | Threaded
Open this post in threaded view
|

Re: SIP Registration rejecting username/password with 401

Sylvain Berfini
In reply to this post by Echedey López Romero

Hi guys,

Indeed this week we have updated flexisip to be able to handle SHA-256 algorithm but it seems to break the register in the old desktop client.

Until we have a fix for this we disabled SHA-256, it should be working again now.

Cheers,

Le 30/08/2019 à 20:58, Echedey a écrit :
Are you using the last version of FlexiSIP server and 4.1.1 version of the desktop client?

Could you test that client with an account on the Linphone SIP service?

I attached my log trying registration on the main service.

30 de agosto de 2019 19:52, "Russell Treleaven" <[hidden email]> escribió:
Latest client on osx is working fine with my own sip server.
On Fri, Aug 30, 2019, 2:45 PM Echedey López Romero <[hidden email]> wrote:
It is strange, this issues only happen on desktop client for some people here. No problem on mobile client.

If its related with the FlexiSIP server from Linphone free SIP service I would prefer wait on a report in the desktop client repo for devs confirmation if its is an issue from server side or client side. It is true that maybe they changed something in the server but that could be a "good change" that mobile clients from them already supported and they must update the desktop client now.

Regards,
Echedey, López RomeroEl 30 ago. 2019 19:25, El Pato <[hidden email]> escribió:
>
> I have 2 PJSIP clients that worked fine for months. They both started failing auth on August 28 around 1:30 in the morning Pacific Daylight Time.
>
> My logs captured the event:
>
> 2019-08-28:2019-08-29,01:34:02.457 WARNING MainThread account.onRegState 0 171100 401 [hidden email] Unauthorized
>
> 2019-08-28:2019-08-29,01:25:57.602 WARNING MainThread onRegState 0 171100 Unauthorized 401
>
> After this event, every subsequent registration fails with "server rejected with stale=false". This has been going on for over 2 days now.
>
> PJSIP Status 171100 = PJSIP_EFAILEDCREDENTIAL.
>
> The docs for PJSIP_EFAILEDCREDENTIAL say
> "Credential failed to authenticate. For this failure, right credential for the realm has been found and used to authenticate against the challenge, but the server has rejected the authorization request with 401/407 response (either with no stale parameter or with "stale=false" parameter). In most cases, this indicates that the username/password combination is incorrect. "
>
> Something is broken with the linphone sip server, it is rejecting valid username/password combinations.
>
_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users


--
Regards,
Echedey, López Romero

_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users

_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users
Reply | Threaded
Open this post in threaded view
|

Re: SIP Registration rejecting username/password with 401

David Pirotte
Hi Sylvain,

> Indeed this week we have updated flexisip to be able to handle
> SHA-256 algorithm but it seems to break the register in the old
> desktop client.
>
> Until we have a fix for this we disabled SHA-256, it should be
> working again now.

I confirm that it is 'working again'

Thanks,
David

_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users

attachment0 (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: SIP Registration rejecting username/password with 401

El Pato
In reply to this post by El Pato
The 401 issue is resolved.  I did have to restart both clients.

THANK YOU!

On Fri, Aug 30, 2019 at 11:25 AM El Pato <[hidden email]> wrote:
I have 2 PJSIP clients that worked fine for months.  They both started failing auth on August 28 around 1:30 in the morning Pacific Daylight Time.

My logs captured the event:

2019-08-28:2019-08-29,01:34:02.457 WARNING MainThread account.onRegState 0 171100 401 [hidden email] Unauthorized

2019-08-28:2019-08-29,01:25:57.602 WARNING MainThread onRegState 0 171100 Unauthorized 401

After this event, every subsequent registration fails with "server rejected with stale=false".  This has been going on for over 2 days now.

PJSIP Status 171100 = PJSIP_EFAILEDCREDENTIAL.

The docs for PJSIP_EFAILEDCREDENTIAL say
"Credential failed to authenticate. For this failure, right credential for the realm has been found and used to authenticate against the challenge, but the server has rejected the authorization request with 401/407 response (either with no stale parameter or with "stale=false" parameter). In most cases, this indicates that the username/password combination is incorrect. "

Something is broken with the linphone sip server, it is rejecting valid username/password combinations.


_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users