Someone forgot to update the version in the makefile

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Someone forgot to update the version in the makefile

Sebastian Nielsen

I just cloned fresh from git://git.linphone.org/linphone.git and when compiling I get the following error:

 

 

if test -n "`cd .. && git log -1 --pretty=format:%H configure.ac`" ; then  \

        if test "`cd .. && git describe --always`" != "" ; then \

                if [ "`cd .. && git describe --abbrev=0`" != "3.11.2" ]; then \

                        /bin/echo "*** PACKAGE_VERSION and git tag differ. Please put them identical."; \

                        exit 1; \

                fi ; \

                printf "#define LIBLINPHONE_GIT_VERSION \"`cd .. && git describe --always`\"\n" > ./liblinphone_gitversion.h.tmp ; \

        elif test "`cd .. && git rev-parse HEAD`" != "" ; then \

                printf "#define LIBLINPHONE_GIT_VERSION \"3.11.2_`cd .. && git rev-parse HEAD`\"\n" > ./liblinphone_gitversion.h.tmp ; \

        else \

                printf "" > ./liblinphone_gitversion.h.tmp ; \

        fi ; \

        if ! test -f ./liblinphone_gitversion.h ; then \

                cp -f ./liblinphone_gitversion.h.tmp ./liblinphone_gitversion.h ; \

        fi ; \

        if test "`cat ./liblinphone_gitversion.h.tmp`" != "`cat ./liblinphone_gitversion.h`" ; then \

                cp -f ./liblinphone_gitversion.h.tmp ./liblinphone_gitversion.h ; \

        fi ; \

        rm -f ./liblinphone_gitversion.h.tmp ; \

else \

        touch liblinphone_gitversion.h ; \

fi

*** PACKAGE_VERSION and git tag differ. Please put them identical.

Makefile:1201: receptet för målet ”make_gitversion_h” misslyckades

make[2]: *** [make_gitversion_h] Fel 1

make[2]: Lämnar katalogen ”/root/linphone/coreapi”

Makefile:610: receptet för målet ”all-recursive” misslyckades

make[1]: *** [all-recursive] Fel 1

make[1]: Lämnar katalogen ”/root/linphone”

Makefile:537: receptet för målet ”all” misslyckades

make: *** [all] Fel 2

 

 

The output of: ” git describe --abbrev=0 ”

Is:

3.12.0

 

So apparently someone forgot to update the make scripts with the correct PACKAGE_VERSION, since PACKAGE_VERSION is 3.11.2.


_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users

smime.p7s (8K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Someone forgot to update the version in the makefile

jehan.monnier
Hi,

We moved from autotools to cmake based build system.
configure.ac/Makefile.am are no longer maintained.

For cmake instructions, I recommend you to look at  https://github.com/BelledonneCommunications/linphone/blob/master/README.md

Best regards



Le 8 oct. 2017 à 04:09, Sebastian Nielsen <[hidden email]> a écrit :

I just cloned fresh from <a href="git://git.linphone.org/linphone.git" style="color: rgb(149, 79, 114); text-decoration: underline;" class="">git://git.linphone.org/linphone.git and when compiling I get the following error:
 
 
if test -n "`cd .. && git log -1 --pretty=format:%H configure.ac`" ; then  \
        if test "`cd .. && git describe --always`" != "" ; then \
                if [ "`cd .. && git describe --abbrev=0`" != "3.11.2" ]; then \
                        /bin/echo "*** PACKAGE_VERSION and git tag differ. Please put them identical."; \
                        exit 1; \
                fi ; \
                printf "#define LIBLINPHONE_GIT_VERSION \"`cd .. && git describe --always`\"\n" > ./liblinphone_gitversion.h.tmp ; \
        elif test "`cd .. && git rev-parse HEAD`" != "" ; then \
                printf "#define LIBLINPHONE_GIT_VERSION \"3.11.2_`cd .. && git rev-parse HEAD`\"\n" > ./liblinphone_gitversion.h.tmp ; \
        else \
                printf "" > ./liblinphone_gitversion.h.tmp ; \
        fi ; \
        if ! test -f ./liblinphone_gitversion.h ; then \
                cp -f ./liblinphone_gitversion.h.tmp ./liblinphone_gitversion.h ; \
        fi ; \
        if test "`cat ./liblinphone_gitversion.h.tmp`" != "`cat ./liblinphone_gitversion.h`" ; then \
                cp -f ./liblinphone_gitversion.h.tmp ./liblinphone_gitversion.h ; \
        fi ; \
        rm -f ./liblinphone_gitversion.h.tmp ; \
else \
        touch liblinphone_gitversion.h ; \
fi
*** PACKAGE_VERSION and git tag differ. Please put them identical.
Makefile:1201: receptet för målet ”make_gitversion_h” misslyckades
make[2]: *** [make_gitversion_h] Fel 1
make[2]: Lämnar katalogen ”/root/linphone/coreapi”
Makefile:610: receptet för målet ”all-recursive” misslyckades
make[1]: *** [all-recursive] Fel 1
make[1]: Lämnar katalogen ”/root/linphone”
Makefile:537: receptet för målet ”all” misslyckades
make: *** [all] Fel 2
 
 
The output of: ” git describe --abbrev=0 ”
Is:
3.12.0
 
So apparently someone forgot to update the make scripts with the correct PACKAGE_VERSION, since PACKAGE_VERSION is 3.11.2.
_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users


_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users
Reply | Threaded
Open this post in threaded view
|

Re: Someone forgot to update the version in the makefile

Sebastian Nielsen

How I supply build arguments to cmake? Like --disable_video --disable-gtk_ui --disable-x11

Because I guess those arguments are different for cmake than automake.

 

Från: Linphone-users [mailto:linphone-users-bounces+sebastian=[hidden email]] För Jehan Monnier
Skickat: den 9 oktober 2017 13:16
Till: [hidden email]
Ämne: Re: [Linphone-users] Someone forgot to update the version in the makefile

 

Hi,

 

We moved from autotools to cmake based build system.

configure.ac/Makefile.am are no longer maintained.

 

For cmake instructions, I recommend you to look at  https://github.com/BelledonneCommunications/linphone/blob/master/README.md

 

Best regards

 

 

 

Le 8 oct. 2017 à 04:09, Sebastian Nielsen <[hidden email]> a écrit :

 

I just cloned fresh from <a href="git://git.linphone.org/linphone.git">git://git.linphone.org/linphone.git and when compiling I get the following error:

 

 

if test -n "`cd .. && git log -1 --pretty=format:%H configure.ac`" ; then  \

        if test "`cd .. && git describe --always`" != "" ; then \

                if [ "`cd .. && git describe --abbrev=0`" != "3.11.2" ]; then \

                        /bin/echo "*** PACKAGE_VERSION and git tag differ. Please put them identical."; \

                        exit 1; \

                fi ; \

                printf "#define LIBLINPHONE_GIT_VERSION \"`cd .. && git describe --always`\"\n" > ./liblinphone_gitversion.h.tmp ; \

        elif test "`cd .. && git rev-parse HEAD`" != "" ; then \

                printf "#define LIBLINPHONE_GIT_VERSION \"3.11.2_`cd .. && git rev-parse HEAD`\"\n" > ./liblinphone_gitversion.h.tmp ; \

        else \

                printf "" > ./liblinphone_gitversion.h.tmp ; \

        fi ; \

        if ! test -f ./liblinphone_gitversion.h ; then \

                cp -f ./liblinphone_gitversion.h.tmp ./liblinphone_gitversion.h ; \

        fi ; \

        if test "`cat ./liblinphone_gitversion.h.tmp`" != "`cat ./liblinphone_gitversion.h`" ; then \

                cp -f ./liblinphone_gitversion.h.tmp ./liblinphone_gitversion.h ; \

        fi ; \

        rm -f ./liblinphone_gitversion.h.tmp ; \

else \

        touch liblinphone_gitversion.h ; \

fi

*** PACKAGE_VERSION and git tag differ. Please put them identical.

Makefile:1201: receptet för målet ”make_gitversion_h” misslyckades

make[2]: *** [make_gitversion_h] Fel 1

make[2]: Lämnar katalogen ”/root/linphone/coreapi”

Makefile:610: receptet för målet ”all-recursive” misslyckades

make[1]: *** [all-recursive] Fel 1

make[1]: Lämnar katalogen ”/root/linphone”

Makefile:537: receptet för målet ”all” misslyckades

make: *** [all] Fel 2

 

 

The output of: ” git describe --abbrev=0 ”

Is:

3.12.0

 

So apparently someone forgot to update the make scripts with the correct PACKAGE_VERSION, since PACKAGE_VERSION is 3.11.2.

_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users

 


_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users

smime.p7s (8K) Download Attachment