Unregister problem

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Unregister problem

Davor Jovanovic
Hi,

I would like to report an unregister problem on exit when having two SIP
accounts. Linphone (ver. 4.2.3 and 4.2.4) for Windows.

Unregister on exit works fine when both accounts have the „Register“
option enabled in their „Main SIP account settings“.

Problem is when I disable the „Register“ option for a secondary SIP
account. When exiting in this scenario the client generates REGISTER SIP
message only for a primary SIP account (as expected) and a SIP server
replies with 401 Unauthorized, but the client does not respond back with
REGISTER SIP message filled with credentials and an unregister process
isn’t successfully finished.


Best regards

/davor

_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users
Reply | Threaded
Open this post in threaded view
|

Re: Unregister problem

Peio Rigaux

Hello.

Thanks for your report.

Could you please reproduce the issue and provide us logs in a reply of this email ?

I'm asking my colleague responsible of the desktop version if he has heard of this bug before.

However, as answers to these mailing lists are individual contributions, I can't guarantee you an answer from him.


Regards,

Peio Rigaux
Junior Software Engineer
Belledonne Communications, the company behind Linphone
Linphone.org

Le 01/12/2020 à 12:08, Davor Jovanovic a écrit :
Hi,

I would like to report an unregister problem on exit when having two SIP accounts. Linphone (ver. 4.2.3 and 4.2.4) for Windows.

Unregister on exit works fine when both accounts have the „Register“ option enabled in their „Main SIP account settings“.

Problem is when I disable the „Register“ option for a secondary SIP account. When exiting in this scenario the client generates REGISTER SIP message only for a primary SIP account (as expected) and a SIP server replies with 401 Unauthorized, but the client does not respond back with REGISTER SIP message filled with credentials and an unregister process isn’t successfully finished.


Best regards

/davor

_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users

_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users

0x99D28356FED78143.asc (3K) Download Attachment
signature.asc (235 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Unregister problem

Davor Jovanovic
Hi Peio,

you can find two files attached, first one is a log from Linphone 4.2.4
and the second one is ngrep log from a server in which you can see that
PBX sends 401 Unathorized message but the Linphone does not respond back
with credentials.

Just to mention once again that everything works fine when both accounts
have Register option enabled in their Settings. It seems that disabling
Register option on a second account somehow affects proper
deregistration process of the first account.

Best regards

/davor


On 12.1.2021. 16:03, Peio Rigaux wrote:

> Hello.
>
> Thanks for your report.
>
> Could you please reproduce the issue and provide us logs in a reply of
> this email ?
>
> I'm asking my colleague responsible of the desktop version if he has
> heard of this bug before.
>
> However, as answers to these mailing lists are individual contributions,
> I can't guarantee you an answer from him.
>
>
> Regards,
>
> Peio Rigaux
> Junior Software Engineer
> Belledonne Communications, the company behind Linphone
> Linphone.org <https://linphone.org/>
>
> Le 01/12/2020 à 12:08, Davor Jovanovic a écrit :
>> Hi,
>>
>> I would like to report an unregister problem on exit when having two
>> SIP accounts. Linphone (ver. 4.2.3 and 4.2.4) for Windows.
>>
>> Unregister on exit works fine when both accounts have the „Register“
>> option enabled in their „Main SIP account settings“.
>>
>> Problem is when I disable the „Register“ option for a secondary SIP
>> account. When exiting in this scenario the client generates REGISTER
>> SIP message only for a primary SIP account (as expected) and a SIP
>> server replies with 401 Unauthorized, but the client does not respond
>> back with REGISTER SIP message filled with credentials and an
>> unregister process isn’t successfully finished.
>>
>>
>> Best regards
>>
>> /davor
>>
>> _______________________________________________
>> Linphone-users mailing list
>> [hidden email]
>> https://lists.nongnu.org/mailman/listinfo/linphone-users

_______________________________________________
Linphone-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/linphone-users

linphone1.log (11K) Download Attachment
ngrep.txt (2K) Download Attachment