Using fluidsynth through pyfluidsynth

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Using fluidsynth through pyfluidsynth

Layers Incorporation
Hello again,

So I tried to download pyfluidsynth (Python bindings for FluidSynth) but when I ran it, an error occurred: "ImportError: Couldn't find the FluidSynth library." it could not find the FluidSynth although I added it to the PATH.

what do you think the problem is?



_______________________________________________
fluid-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/fluid-dev
Reply | Threaded
Open this post in threaded view
|

Re: Using fluidsynth through pyfluidsynth

Ceresa Jean-Jacques

Hello,

 

There is a bunch of Python bindings for Fluidsynth elsewere. It is unlikely that any of these are compatible with any fluidsynth release version.

Each time a python binding package is done a minimum of documentation should be given describing which Fluidsynth version is required and which API is bounded.

Also when a python package is installed it should be mentionned if the fluidsynth shared library is installed in python directory or not.

Actual pyFluidSynth python module is for fluidsynth version 1.07 and the author said that version above are untested.

As a general use case, fluidsynth version < 1.1.0 should be avoided. More information see http://www.fluidsynth.org/api-1.x/.

jjc.

 


_______________________________________________
fluid-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/fluid-dev