Xerces question (installation requirements).

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Xerces question (installation requirements).

Γιώργος Κωστόπουλος
Hi!  :-)

I was trying to install it, on a Debian oldstable based distro (x64).

From website (https://www.nongnu.org/enigma/download.html#compilation):

If you're using Debian, you should have the following packages
installed for compiling the SVN developmental version:

libxerces27-dev
curl
libcurl3-openssl-dev or libcurl4-openssl-dev
libsdl1.2-dev
libsdl-image1.2-dev
libsdl-mixer1.2-dev
libsdl-sound1.2-dev
libsdl-ttf2.0-dev
libxerces27-dev

Question 1: Does  libxerces27-dev, appears on the top AND the down of the list?
Ehm...Am I missing something?  :-)

Question 2: Debian doesn't seems to have that library! At least, not any more.
https://packages.debian.org/search?keywords=xerces&searchon=names&suite=all&section=all&sourceid=mozilla-search

I think libxerces-c-dev, is the needed package.
Is it true? (or not)?  :-)

BTW, Happy New |Year everyone!!!
G.

Reply | Threaded
Open this post in threaded view
|

Re: Xerces question (installation requirements).

Erich Schubert-2
Hi,

Debian has an "enigma" package. It could need some updating (I do not
have time for it anymore, so it needs a new maintainer), but the build
logic will likely work without changes.

You can check the build dependencies of the package in the
debian/control file:

https://sources.debian.org/src/enigma/1.20-dfsg.1-2.1/debian/control/

Regards,
Erich Schubert

Am 05.01.20 um 17:37 schrieb Γιώργος Κωστόπουλος:

> Hi!  :-)
>
> I was trying to install it, on a Debian oldstable based distro (x64).
>
> From website (https://www.nongnu.org/enigma/download.html#compilation):
>
> If you're using Debian, you should have the following packages
> installed for compiling the SVN developmental version:
>
> libxerces27-dev
> curl
> libcurl3-openssl-dev or libcurl4-openssl-dev
> libsdl1.2-dev
> libsdl-image1.2-dev
> libsdl-mixer1.2-dev
> libsdl-sound1.2-dev
> libsdl-ttf2.0-dev
> libxerces27-dev
>
> Question 1: Does  libxerces27-dev, appears on the top AND the down of the list?
> Ehm...Am I missing something?  :-)
>
> Question 2: Debian doesn't seems to have that library! At least, not any more.
> https://packages.debian.org/search?keywords=xerces&searchon=names&suite=all&section=all&sourceid=mozilla-search
>
> I think libxerces-c-dev, is the needed package.
> Is it true? (or not)?  :-)
>
> BTW, Happy New |Year everyone!!!
> G.
>

Reply | Threaded
Open this post in threaded view
|

Re: Xerces question (installation requirements).

Γιώργος Κωστόπουλος
Στις Κυρ, 5 Ιαν 2020 στις 10:00 μ.μ., ο/η Erich Schubert
<[hidden email]> έγραψε:

>
> Hi,
>
> Debian has an "enigma" package. It could need some updating (I do not
> have time for it anymore, so it needs a new maintainer), but the build
> logic will likely work without changes.
>
> You can check the build dependencies of the package in the
> debian/control file:
>
> https://sources.debian.org/src/enigma/1.20-dfsg.1-2.1/debian/control/
>
> Regards,
> Erich Schubert
>
>

Indeed libxerces-c-dev, is what needed! :-)
THANKS Erich!!!
G.

PS. The Debian package can't run here.
It gives me a segfault ans exits.
That's why, I was trying to build it locally. :-)
I'll be back!

PS2. HAPPY NEW YEAR everyone!!!