[bug #17295] xlator to be renamed

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[bug #17295] xlator to be renamed

Eric L.-2

URL:
  <http://savannah.nongnu.org/bugs/?func=detailitem&item_id=17295>

                 Summary: xlator to be renamed
                 Project: Gluster
            Submitted by: avati
            Submitted on: Thursday 08/03/2006 at 18:30
                Category: GlusterFS
                Severity: 2 - Minor
                Priority: 5 - Normal
              Item Group: Bad naming convention
                  Status: None
                 Privacy: Public
             Assigned to: None
             Open/Closed: Open
        Operating System: GNU/Linux

    _______________________________________________________

Details:

xlator names  should be of the type 'Category-Name'

Brick => 'Transport-Socket'
Posix => 'FS-Posix'
Cement => 'Sched-Union'






    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?func=detailitem&item_id=17295>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/



_______________________________________________
Gluster-devel mailing list
[hidden email]
http://lists.nongnu.org/mailman/listinfo/gluster-devel
Reply | Threaded
Open this post in threaded view
|

[bug #17295] xlator to be renamed

Eric L.-2

Update of bug #17295 (project gluster):

             Assigned to:                    None => gowda                  

    _______________________________________________________

Follow-up Comment #1:

should update -

* Makefile.am (all of them)
* configure.ac
* rename directories
* rename files


    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?func=detailitem&item_id=17295>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/



_______________________________________________
Gluster-devel mailing list
[hidden email]
http://lists.nongnu.org/mailman/listinfo/gluster-devel
Reply | Threaded
Open this post in threaded view
|

[bug #17295] xlator to be renamed

Eric L.-2

Update of bug #17295 (project gluster):

             Assigned to:                   gowda => avati                  


    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?func=detailitem&item_id=17295>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/



_______________________________________________
Gluster-devel mailing list
[hidden email]
http://lists.nongnu.org/mailman/listinfo/gluster-devel
Reply | Threaded
Open this post in threaded view
|

[bug #17295] xlator to be renamed

Eric L.-2

Update of bug #17295 (project gluster):

                  Status:                    None => Fixed                  
             Open/Closed:                    Open => Closed                

    _______________________________________________________

Follow-up Comment #2:

all xlators are now in lower case.
xlators have been renamed as category/name. there is a top level category
directory and sub directory for actual xlator.

summary of categories and renaming done -

1. Transport category (xport)
   Brick -> xport/socket

2. Optimizers/performance booster category (steroid)
   getattr -> steroid/stat-prefetch

3. Storage/File system category (storage)
   Posix -> storage/posix

4. Schedulers category (sched)
   Cement -> sched/unify


filter xlator is under discussion for its design still. One proposal -

--porposal--

5. Filtering category (filter)
   filter/read-only
   filter/hide
   filter/block
   filter/file-size-limit

each of those will be seperate translators under the filter category. more
discussion to be done about chaining of multiple xlators of filter or group
them into one (and effect of both approaches) to be done.
--end-proposal--


since all translators so far are following the discipline of declaring all
functions  static there is no namespace issues (yet).

all inner variable and function names are to be renamed by
translator authors to follow the new naming convention


    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?func=detailitem&item_id=17295>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/



_______________________________________________
Gluster-devel mailing list
[hidden email]
http://lists.nongnu.org/mailman/listinfo/gluster-devel