[bug #17318] build fails on x86_64

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[bug #17318] build fails on x86_64

Eric L.-2

URL:
  <http://savannah.nongnu.org/bugs/?func=detailitem&item_id=17318>

                 Summary: build fails on x86_64
                 Project: Gluster
            Submitted by: vikasgp
            Submitted on: Friday 08/04/2006 at 19:31
                Category: GlusterFS
                Severity: 4 - Important
                Priority: 5 - Normal
              Item Group: Build failure
                  Status: None
                 Privacy: Public
             Assigned to: None
             Open/Closed: Open
        Operating System: GNU/Linux

    _______________________________________________________

Details:

build fails on x86_64, due to the fact that non-PIC code cannot be linked
into a shared library.
However, the solution given in
http://www.x86-64.org/lists/discuss/msg05760.html doesn't work.






    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?func=detailitem&item_id=17318>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/



_______________________________________________
Gluster-devel mailing list
[hidden email]
http://lists.nongnu.org/mailman/listinfo/gluster-devel
Reply | Threaded
Open this post in threaded view
|

[bug #17318] build fails on x86_64

Eric L.-2

Update of bug #17318 (project gluster):

                  Status:                    None => Fixed                  

    _______________________________________________________

Follow-up Comment #1:

CFLAGS=-fPIC while running configure is a fix.

    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?func=detailitem&item_id=17318>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/



_______________________________________________
Gluster-devel mailing list
[hidden email]
http://lists.nongnu.org/mailman/listinfo/gluster-devel
Reply | Threaded
Open this post in threaded view
|

[bug #17318] build fails on x86_64

Eric L.-2

Update of bug #17318 (project gluster):

             Open/Closed:                    Open => Closed                


    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?func=detailitem&item_id=17318>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/



_______________________________________________
Gluster-devel mailing list
[hidden email]
http://lists.nongnu.org/mailman/listinfo/gluster-devel