[bug #18270] Customizing emacs-wiki-url-protocols has no effect

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[bug #18270] Customizing emacs-wiki-url-protocols has no effect

Eric L.-2

URL:
  <http://savannah.nongnu.org/bugs/?18270>

                 Summary: Customizing emacs-wiki-url-protocols has no effect
                 Project: emacs-wiki, planner, and related modules
            Submitted by: None
            Submitted on: Sonntag 12.11.2006 um 17:02 UTC
                Category: emacs-wiki
                Severity: 3 - Normal
              Item Group: None
                  Status: None
                 Privacy: Public
             Assigned to: None
             Open/Closed: Open

    _______________________________________________________

Details:

Emacs-Wiki version 2.72

Changing the value of emacs-wiki-url-protocols has no effect if you use
Emacs' customization interface. The new value is put at the end of ~/.emacs,
but Emacs-Wiki is also loaded by an explicit "(require 'emacs-wiki)" in
~/.emacs, *before* the customization values.

I guess when Emacs-Wiki is loaded, the value for emacs-wiki-url-regexp is
initialized. This should probably be delayed to the moment when the first
wiki page is opened. At that moment, the values for customized variables are
available.






    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?18270>

_______________________________________________
  Nachricht geschickt von/durch Savannah
  http://savannah.nongnu.org/



_______________________________________________
emacs-wiki-discuss mailing list
[hidden email]
http://lists.nongnu.org/mailman/listinfo/emacs-wiki-discuss