[bug #40650] WeeChat Requires rubylib.so

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[bug #40650] WeeChat Requires rubylib.so

Eric L.-2
URL:
  <http://savannah.nongnu.org/bugs/?40650>

                 Summary: WeeChat Requires rubylib.so
                 Project: WeeChat
            Submitted by: None
            Submitted on: Wed 20 Nov 2013 08:01:50 PM UTC
                Category: None
                Severity: 3 - Normal
              Item Group: None
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name:
        Originator Email: [hidden email]
             Open/Closed: Open
         Discussion Lock: Any
                 Release: 0.4.2
                IRC nick:

    _______________________________________________________

Details:

Much like a bug that was in vim [1], weechat requires rubylib.so which on some
linux distros requires ruby-devel to be installed (of course on most
production servers, which many run weechat or irssi on for screen, they do not
use ruby-devel).

[1] https://groups.google.com/forum/?fromgroups=#!topic/vim_dev/ifgqrTYEeCM




    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?40650>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/


_______________________________________________
Weechat-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/weechat-dev
Reply | Threaded
Open this post in threaded view
|

[bug #40650] WeeChat Requires rubylib.so

Eric L.-2
Update of bug #40650 (project weechat):

                Category:                    None => script API plugins    
              Item Group:                    None => compile/install        
                  Status:                    None => Need Info              
             Assigned to:                    None => flashcode              

    _______________________________________________________

Follow-up Comment #1:

I'm not sure if WeeChat (I mean ruby plugin) is affected by this problem
(after looking at the ruby detection in WeeChat, it seems different from your
URL).

On which distribution do you have the problem with WeeChat/ruby ?

And more important, do you have the problem with cmake (recommended way to
compile WeeChat) or with autotools (./configure) ?

    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?40650>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/


_______________________________________________
Weechat-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/weechat-dev