build failure

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

build failure

J Decker
Arch Linux has no package for monotone.
it installs a Botan-1.11(?) as 'Botan'

I tried to link; but it doesn't compele for a variety of c++14
errors... in configure

checking for botan using botan-1.11.pc... yes
checking whether botan is usable... no
configure: *** botan_CFLAGS=-I/usr/include/botan-1.11
configure: *** botan_LIBS=-lbotan-1.11
configure: error: in `/home/d3x0r/addons/srcpit/monotone-1.1':
configure: error: Must be able to compile and link programs against botan.

| /usr/lib/pkgconfig/botan-1.11.pc
configure:5066: checking for botan using botan-1.11.pc
configure:5075: $PKG_CONFIG --exists --print-errors "$c$_verreq"
configure:5078: $? = 0
configure:5093: $PKG_CONFIG --exists --print-errors "$c$_verreq"
configure:5096: $? = 0
configure:5109: result: yes
configure:5182: checking whether botan is usable
configure:5206: g++ -o conftest -g -O2 -Wall -W -Wno-unused
-I/usr/include/botan-1.11  conftest.cpp -lz  -lbotan-1.11 >&5
In file included from /usr/include/c++/5.3.0/cstdint:35:0,
                 from /usr/include/botan-1.11/botan/types.h:15,
                 from /usr/include/botan-1.11/botan/scan_name.h:11,
                 from /usr/include/botan-1.11/botan/block_cipher.h:11,
                 from /usr/include/botan-1.11/botan/lookup.h:11,
                 from /usr/include/botan-1.11/botan/botan.h:11,
                 from conftest.cpp:14:
/usr/include/c++/5.3.0/bits/c++0x_warning.h:32:2: error: #error This
file requires compiler and library support for the ISO C++ 2011
standard. This support must be enabled with the -std=c++11 or
-std=gnu++11 compiler options.
 #error This file requires compiler and library support \
  ^
In file included from /usr/include/botan-1.11/botan/sym_algo.h:12:0,
                 from /usr/include/botan-1.11/botan/block_cipher.h:12,
                 from /usr/include/botan-1.11/botan/lookup.h:11,
                 from /usr/include/botan-1.11/botan/botan.h:11,
                 from conftest.cpp:14:
/usr/include/botan-1.11/botan/exceptn.h:27:7: warning: identifier
'noexcept' is a keyword in C++11 [-Wc++0x-compat]
       const char* what() const BOTAN_NOEXCEPT override { return
m_what.c_str(); }
       ^
In file included from /usr/include/botan-1.11/botan/secmem.h:17:0,
                 from /usr/include/botan-1.11/botan/symkey.h:11,

_______________________________________________
Monotone-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/monotone-devel
Reply | Threaded
Open this post in threaded view
|

Re: build failure

Markus Wanner-2
On 03/03/2016 03:37 AM, J Decker wrote:
> Arch Linux has no package for monotone.
> it installs a Botan-1.11(?) as 'Botan'

You reported this before and were told that Botan 1.11 is a development
branch. Please compile Monotone against 1.10, instead. (Or 1.6 or 1.8,
if you insist.)

Plus: archaurwiki even reported he created a botan-stable and a matching
monotone package for arch.

Regards

Markus Wanner


_______________________________________________
Monotone-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/monotone-devel
Reply | Threaded
Open this post in threaded view
|

Re: build failure

archaurwiki
In reply to this post by J Decker
Arch Linux *does* have a package for monotone:

https://aur4.archlinux.org/packages/monotone/

It builds against botan stable.

Simply issue:

yaourt -Syua monotone

or

git clone https://aur.archlinux.org/monotone.git
cd monotone && makepkg -s


J Decker:

> Arch Linux has no package for monotone.
> it installs a Botan-1.11(?) as 'Botan'
>
> I tried to link; but it doesn't compele for a variety of c++14
> errors... in configure
>
> checking for botan using botan-1.11.pc... yes
> checking whether botan is usable... no
> configure: *** botan_CFLAGS=-I/usr/include/botan-1.11
> configure: *** botan_LIBS=-lbotan-1.11
> configure: error: in `/home/d3x0r/addons/srcpit/monotone-1.1':
> configure: error: Must be able to compile and link programs against botan.
>
> | /usr/lib/pkgconfig/botan-1.11.pc
> configure:5066: checking for botan using botan-1.11.pc
> configure:5075: $PKG_CONFIG --exists --print-errors "$c$_verreq"
> configure:5078: $? = 0
> configure:5093: $PKG_CONFIG --exists --print-errors "$c$_verreq"
> configure:5096: $? = 0
> configure:5109: result: yes
> configure:5182: checking whether botan is usable
> configure:5206: g++ -o conftest -g -O2 -Wall -W -Wno-unused
> -I/usr/include/botan-1.11  conftest.cpp -lz  -lbotan-1.11 >&5
> In file included from /usr/include/c++/5.3.0/cstdint:35:0,
>                  from /usr/include/botan-1.11/botan/types.h:15,
>                  from /usr/include/botan-1.11/botan/scan_name.h:11,
>                  from /usr/include/botan-1.11/botan/block_cipher.h:11,
>                  from /usr/include/botan-1.11/botan/lookup.h:11,
>                  from /usr/include/botan-1.11/botan/botan.h:11,
>                  from conftest.cpp:14:
> /usr/include/c++/5.3.0/bits/c++0x_warning.h:32:2: error: #error This
> file requires compiler and library support for the ISO C++ 2011
> standard. This support must be enabled with the -std=c++11 or
> -std=gnu++11 compiler options.
>  #error This file requires compiler and library support \
>   ^
> In file included from /usr/include/botan-1.11/botan/sym_algo.h:12:0,
>                  from /usr/include/botan-1.11/botan/block_cipher.h:12,
>                  from /usr/include/botan-1.11/botan/lookup.h:11,
>                  from /usr/include/botan-1.11/botan/botan.h:11,
>                  from conftest.cpp:14:
> /usr/include/botan-1.11/botan/exceptn.h:27:7: warning: identifier
> 'noexcept' is a keyword in C++11 [-Wc++0x-compat]
>        const char* what() const BOTAN_NOEXCEPT override { return
> m_what.c_str(); }
>        ^
> In file included from /usr/include/botan-1.11/botan/secmem.h:17:0,
>                  from /usr/include/botan-1.11/botan/symkey.h:11,
>
> _______________________________________________
> Monotone-devel mailing list
> [hidden email]
> https://lists.nongnu.org/mailman/listinfo/monotone-devel
>

_______________________________________________
Monotone-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/monotone-devel
Reply | Threaded
Open this post in threaded view
|

Re: build failure

J Decker
[root@tower2 firewall]# pacman -Sq monotone
error: target not found: monotone
[root@tower2 firewall]# pacman -Syu monotone
:: Synchronizing package databases...
 core                                    121.7 KiB   231K/s 00:01
[####################################] 100%
 extra                                  1768.1 KiB   346K/s 00:05
[####################################] 100%
 community                                 3.4 MiB   332K/s 00:10
[####################################] 100%
error: target not found: monotone

[root@tower2 monotone]# pacman -Sq botan-stable
error: target not found: botan-stable

I have no yaourt

https://aur4.archlinux.org/packages/botan-stable/

after git clone of botan stable
makepkg -s
......

==> Verifying source file signatures with gpg...
    Botan-1.10.12.tgz ... FAILED (the public key
621DAF6411E1851C4CF9A2E16211EBF1EFBADFBC is not trusted)
==> ERROR: One or more PGP signatures could not be verified!

-------------
finally found yaourt

[d3x0r@tower2 yaourt]$ makepkg -sri
==> Making package: yaourt 1.8-1 (Thu Mar  3 13:27:01 PST 2016)
==> Checking runtime dependencies...
==> Installing missing dependencies...
error: target not found: package-query>=1.8
==> ERROR: 'pacman' failed to install missing dependencies.


found your last message from 9/5/15 (sorry it was 6 months ago so I
forgot I noted this before)
tried that gpg recv-key too... but no help....

On Thu, Mar 3, 2016 at 10:42 AM, archaurwiki <[hidden email]> wrote:

> Arch Linux *does* have a package for monotone:
>
> https://aur4.archlinux.org/packages/monotone/
>
> It builds against botan stable.
>
> Simply issue:
>
> yaourt -Syua monotone
>
> or
>
> git clone https://aur.archlinux.org/monotone.git
> cd monotone && makepkg -s
>
>
> J Decker:
>> Arch Linux has no package for monotone.
>> it installs a Botan-1.11(?) as 'Botan'
>>
>> I tried to link; but it doesn't compele for a variety of c++14
>> errors... in configure
>>
>> checking for botan using botan-1.11.pc... yes
>> checking whether botan is usable... no
>> configure: *** botan_CFLAGS=-I/usr/include/botan-1.11
>> configure: *** botan_LIBS=-lbotan-1.11
>> configure: error: in `/home/d3x0r/addons/srcpit/monotone-1.1':
>> configure: error: Must be able to compile and link programs against botan.
>>
>> | /usr/lib/pkgconfig/botan-1.11.pc
>> configure:5066: checking for botan using botan-1.11.pc
>> configure:5075: $PKG_CONFIG --exists --print-errors "$c$_verreq"
>> configure:5078: $? = 0
>> configure:5093: $PKG_CONFIG --exists --print-errors "$c$_verreq"
>> configure:5096: $? = 0
>> configure:5109: result: yes
>> configure:5182: checking whether botan is usable
>> configure:5206: g++ -o conftest -g -O2 -Wall -W -Wno-unused
>> -I/usr/include/botan-1.11  conftest.cpp -lz  -lbotan-1.11 >&5
>> In file included from /usr/include/c++/5.3.0/cstdint:35:0,
>>                  from /usr/include/botan-1.11/botan/types.h:15,
>>                  from /usr/include/botan-1.11/botan/scan_name.h:11,
>>                  from /usr/include/botan-1.11/botan/block_cipher.h:11,
>>                  from /usr/include/botan-1.11/botan/lookup.h:11,
>>                  from /usr/include/botan-1.11/botan/botan.h:11,
>>                  from conftest.cpp:14:
>> /usr/include/c++/5.3.0/bits/c++0x_warning.h:32:2: error: #error This
>> file requires compiler and library support for the ISO C++ 2011
>> standard. This support must be enabled with the -std=c++11 or
>> -std=gnu++11 compiler options.
>>  #error This file requires compiler and library support \
>>   ^
>> In file included from /usr/include/botan-1.11/botan/sym_algo.h:12:0,
>>                  from /usr/include/botan-1.11/botan/block_cipher.h:12,
>>                  from /usr/include/botan-1.11/botan/lookup.h:11,
>>                  from /usr/include/botan-1.11/botan/botan.h:11,
>>                  from conftest.cpp:14:
>> /usr/include/botan-1.11/botan/exceptn.h:27:7: warning: identifier
>> 'noexcept' is a keyword in C++11 [-Wc++0x-compat]
>>        const char* what() const BOTAN_NOEXCEPT override { return
>> m_what.c_str(); }
>>        ^
>> In file included from /usr/include/botan-1.11/botan/secmem.h:17:0,
>>                  from /usr/include/botan-1.11/botan/symkey.h:11,
>>
>> _______________________________________________
>> Monotone-devel mailing list
>> [hidden email]
>> https://lists.nongnu.org/mailman/listinfo/monotone-devel
>>
>
> _______________________________________________
> Monotone-devel mailing list
> [hidden email]
> https://lists.nongnu.org/mailman/listinfo/monotone-devel

_______________________________________________
Monotone-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/monotone-devel