cannot get Dazuko 2.3.3-pre1 to work on 2.6.20

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

cannot get Dazuko 2.3.3-pre1 to work on 2.6.20

Mikhail A
Hello!
I cannot get Dazuko to work on my computer.

When I try with --enable-syscalls, the module does not compile:

make -C /lib/modules/2.6.20-gentoo/build
SUBDIRS="/home/mafanasyev/src/dazuko-2.3.3-pre1" modules
make[1]: Entering directory `/usr/src/linux-2.6.20-gentoo'
  CC [M]  /home/mafanasyev/src/dazuko-2.3.3-pre1/dazuko_core.o
/home/mafanasyev/src/dazuko-2.3.3-pre1/dazuko_core.c:72: error:
redefinition of `struct path'

Without --enable-syscall, the module compiles, but does not load:
# sudo insmod dazuko.ko
insmod: error inserting 'dazuko.ko': -1 Invalid parameters
# dmesg|tail -n 1
[627182.552103] dazuko: failed to register

Additional information:
* configure output:

=======================
 Configuration summary
=======================

module events = ON_OPEN ON_EXEC ON_INIT_MODULE
devfs support = no
rsbac support = no
stacking support = no
local __d_path() = no (using chroot events, see README.linux26)
module debug = no
library 1.x compatibility = yes

* loaded modules
# lsmod
Module                  Size  Used by
commoncap               6272  0
rlocate                12580  0
keyspan                47152  1
3c59x                  41324  0
i2c_i801                8204  0
intel_agp              21148  1
agpgart                28748  1 intel_agp


* current kernel config:
 [ ] Enable access key retention support

 [*] Enable different security models

 [*]   Socket and Networking Security Hooks

 [ ]     XFRM (IPSec) Networking Security Hooks

 <M>   Default Linux Capabilities

 < >   Root Plug Support

 [ ] NSA SELinux Support


Thanks in advance!
Mikhail


_______________________________________________
Dazuko-devel mailing list
[hidden email]
http://lists.nongnu.org/mailman/listinfo/dazuko-devel
Reply | Threaded
Open this post in threaded view
|

Re: cannot get Dazuko 2.3.3-pre1 to work on 2.6.20

John Ogness-2
Mikhail A wrote:
> When I try with --enable-syscalls, the module does not compile:

This has been fixed in CVS. A new pre-release will be posted soon.


> Without --enable-syscall, the module compiles, but does not load:

Hmmm, everything looks ok. Are you able to load the capability module?

# modprobe capability
# modprobe -r capability

If not, the configuration you posted my not match that of the running
kernel.

John Ogness

--
Dazuko Maintainer



_______________________________________________
Dazuko-devel mailing list
[hidden email]
http://lists.nongnu.org/mailman/listinfo/dazuko-devel