duplicity restore question

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

duplicity restore question

duplicity-talk mailing list
Hello,

I recently setup duplicity on a computer running ubuntu.  I setup a
backup routine that backs up certain folders on the machine to backblaze
using the tutorial here:

https://help.backblaze.com/hc/en-us/articles/115001518354

I have the backup working fine but am unable to do a restore. I've tried
restoring files a couple of different ways.

After downloading the files from backblaze via web browser I tried the
basic restore as follows:

$ duplicity restore --file-to-restore '/path to backup' '/path to /restore location'

but duplicity repeatedly says that the backup does not contain the requested folders.

So to check to see what the backup contains I enter the following command:

sudo duplicity list-current-files file:///path/to/backup folder'

That command returns nothing more than the date of the backup and a period like so:  "Wed Feb 21 16:26:05 2018 ."

It does not list the contents of the backup.

If I could at least get the contents of the backup I could make sure I have the correct paths to do a restore.

Also, is it possible to restore the entire backup?  To attempt that I tried the following:

sudo duplicity restore 'file:///path to/backup' '/path to/restore'

That gives me the same result as trying to list current files.  Nothing is ever restored after it churns for several hours.

Any thoughts on why I can list the current files in my backup or restore the entire backup?  The result is the same whether I attempt to restore
the local files or directly from backblaze.

thanks,
Jared




_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk