error: "Do not use this version of timeclock.el with Emacs"

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

error: "Do not use this version of timeclock.el with Emacs"

Dong Wang-4
Thanks! Suno Ano

but I have a new problem :(

I added

(require 'planner-timeclock)
(require 'planner-timeclock-summary)

to my .emacs,
but got an error when start up:

"Do not use this version of timeclock.el with Emacs"

and the version of my emacs is 22.3.
is there suitable version of contrib/timeclock.el to Emacs22.3?

Thanks.

Best Regards.

--
Dong Wang

_______________________________________________
Planner-el-discuss mailing list
[hidden email]
https://mail.gna.org/listinfo/planner-el-discuss
Reply | Threaded
Open this post in threaded view
|

Re: error: "Do not use this version of timeclock.el with Emacs"

Suno Ano
 Dong> And the version of my emacs is 22.3. Is there suitable version of
 Dong> contrib/timeclock.el to Emacs22.3?

Well I am on

,----[ lsb_release -ric ]
| Distributor ID: Debian
| Release: unstable
| Codename: sid
`----

and use emacs from http://emacs.orebokech.com/. I am not using
planner-timeclock.el. However, I just tried evaluating

 Dong> (Require 'planner-timeclock) (require 'planner-timeclock-summary)

and it works just fine here. My planner version is

,----[ C-h v planner-version RET ]
| planner-version is a variable defined in `planner.el'.
| Its value is "3.42"
|
| Documentation:
| The version of Planner currently loaded.
|
| [back]
`----

which I update from git i.e. I am always with up to date planner code
http://wjsullivan.net/static/doc/planner/planner-el.html#Installing-from-git


_______________________________________________
Planner-el-discuss mailing list
[hidden email]
https://mail.gna.org/listinfo/planner-el-discuss
Reply | Threaded
Open this post in threaded view
|

Re: error: "Do not use this version of timeclock.el with Emacs"

John Sullivan-2
In reply to this post by Dong Wang-4
"Dong Wang" <[hidden email]> writes:

> Thanks! Suno Ano
>
> but I have a new problem :(
>
> I added
>
> (require 'planner-timeclock)
> (require 'planner-timeclock-summary)
>
> to my .emacs,
> but got an error when start up:
>
> "Do not use this version of timeclock.el with Emacs"

Hm, that shouldn't happen. What does M-x locate-library RET timeclock
RET say?


--
John Sullivan
Emacs Planner Maintainer
http://wjsullivan.net/PlannerMode.html
GPG Key: AE8600B6

_______________________________________________
Planner-el-discuss mailing list
[hidden email]
https://mail.gna.org/listinfo/planner-el-discuss