fastbuild won't - Fedora 14

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

fastbuild won't - Fedora 14

cbuckingham
Hello list members.

After having troubles with compiling under Solaris I decided to try
another O/S, one which had a repository with sks. I installed
Fedora 14, with all the usual packages, on a dual core 3GHz Intel.

After installing SKS and setting up the directory, downloading the
key-dumps (4 Nov - key-server.de) and sorting out some
dependencies, I set off the sks_build.sh.  After only 5 mins the
following error occurs:

=== Running fastbuild... ===
Fatal error: exception Invalid_argument("Array.make")
Command failed unexpectedly. Bailing out

From fastbuild.log:
2010-11-08 22:21:15 Opening log
2010-11-08 22:21:15 Opening KeyDB database
2010-11-08 22:21:16 Loading 1050000 keys at a time
2010-11-08 22:21:16 Loading metadata...
2010-11-08 22:24:28    1050000 keys loaded, 124 files left

I went back through all of the dependencies to make certain they
were all their, then I checked the dependencies of the
dependencies. Everything that I need to run SKS is there.  It could
be that I was trying to load to many keys at once even though I
have enough memory and sys-resources, so set it to load 50k keys at
a time... It just took a lot longer to fail with the same error.

As a last resort I removed the repository SKS package, compiled it
from source and installed. Still the same error.

Anyone seen this before?

Packages installed for SKS are:
gcc 4.5.1-4.fc14
gmake 3.82
gdbm-devel 1.8.3-6.fc14
SKS 1.1.1-4.fc14
DB4 4.8.30-2.fc14
compat-db47 4.7.25-17.fc14
compat-db46 4.6.21-17.fc14
Ocaml 3.11.2-2.fc13
ocaml-runtime 3.11.2-2.fc13
bash 4.1.7-3.fc14
glibc 2.12.90-18
ncurses-libs 5.7-8.20100703.fc14


Cheers,
CB


_______________________________________________
Sks-devel mailing list
[hidden email]
http://lists.nongnu.org/mailman/listinfo/sks-devel