new version does not run sometimes

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

new version does not run sometimes

efhorry efhorry
Hello
my test level ne0999

at
https://drive.google.com/folderview?id=0B3QD7L9bSWAHakl5Zm5mMzM5RU0&usp=sharing
did run with previous version of enigma
http://lists.nongnu.org/archive/html/enigma-devel/2010-05/msg00005.html
but new version crushes on windows 7 and windows xp
without throwing an error exception
problem is probably with lines like
wo[{x,y+1}] = ti["+ "] .. ti["a "]
in function oxyd_callback

bye Emanuel Funiok
https://sites.google.com/site/levelsforgames/


_______________________________________________
Enigma-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/enigma-devel
Reply | Threaded
Open this post in threaded view
|

Re: new version does not run sometimes

Andreas Lochmann-2

Hi,

you call "enigma.GetPos" in a 1.10-level - this yields
a call to nil. You have to replace it by po(sender),
in your case change

          [...]
          local x,y = enigma.GetPos(sender)
          wo[{x,y+1}] = ti["+ "] .. ti["a "]  
          local x,y = enigma.GetPos(last_oxyd)
          wo[{x,y+1}] = ti["+ "] .. ti["a "]  
          [...]

to

          [...]
          wo[po(sender) + {0,1}] = ti["+ "] .. ti["a "]  
          wo[po(last_oxyd) + {0,1}] = ti["+ "] .. ti["a "]  
          [...]

This still doesn't work: You are killing the sender in your
callback in the next line! Never kill the sender.
If you take a look at the opal-levels, you will notice that
we just plant a seed which will later kill the oxyd. Here,
you have to work around this.

Even after this, the code fails. You have to add

          wo["AllowSingleOxyds"] = true

if you are manipulating oxyds. After this, you have to
make sure yourself, that all colors match afterwards.

One more thing:
For lasers, switchs and triggers, you should definitely
use autotiling.

Best,
Andreas


Am 08.04.2013 21:49, schrieb efhorry efhorry:
Hello
my test level ne0999

at 
https://drive.google.com/folderview?id=0B3QD7L9bSWAHakl5Zm5mMzM5RU0&usp=sharing


did run with previous version of enigma
http://lists.nongnu.org/archive/html/enigma-devel/2010-05/msg00005.html
but new version crushes on windows 7 and windows xp
without throwing an error exception
problem is probably with lines like
wo[{x,y+1}] = ti["+ "] .. ti["a "]
in function oxyd_callback
bye
Emanuel Funiok
https://sites.google.com/site/levelsforgames/ 



_______________________________________________
Enigma-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/enigma-devel



_______________________________________________
Enigma-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/enigma-devel
Reply | Threaded
Open this post in threaded view
|

Re: new version does not run sometimes

Raoul-3
In reply to this post by efhorry efhorry
Hi,

> did run with previous version of enigma
> but new version crushes on windows 7 and windows xp<br>

The reason is that the level code is hopelessly buggy.


-- Raoul

_______________________________________________
Enigma-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/enigma-devel
Reply | Threaded
Open this post in threaded view
|

Re: new version does not run sometimes

Raoul-3
In reply to this post by Andreas Lochmann-2
Hi,


Thanks for the detailed analysis Andreas.


-- Raoul

_______________________________________________
Enigma-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/enigma-devel