noauth sks issue

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

noauth sks issue

gabrix-4
Hi!
Db port for my sks keyserver pgp.gabrix.ath.cx 11371 has an issue.
Looking at logs i have found this:

> 2009-12-15 20:50:21 Error handling request (GET,/pks/lookup?op=index&options=mr&search=google,com,[
> host:127.0.0.1:11371]): Invalid_argument("Too many responses")
> 2009-12-15 20:50:21 Error handling request (GET,/pks/lookup?op=index&options=mr&search=google.com,[
> host:192.168.1.2:11371]): Invalid_argument("Too many responses")
> 2009-12-15 20:50:25 Error handling request (GET,/pks/lookup?op=index&options=mr&search=gabrix.ath.cx,[
> host:192.168.1.2:11371]): Sys_error("Broken pipe")

> 2009-12-16 03:06:26 Malformed entry

> 2009-12-15 20:50:08 Raising Sys.Break -- PTree may be corrupted: Failure("add_to_node: attempt to reinsert element into prefix tree")

I'm new to this error logs what do they mean ?
Thanks

Gab
--
1024D/BC4F9423 2008-12-05
Key fingerprint = 36C6 E257 2801 46E7 69A7  8721 F502 1342 BC4F 9423
ASCII ribbon campaign ( )
  against HTML e-mail   X
                       / \



_______________________________________________
Sks-devel mailing list
[hidden email]
http://lists.nongnu.org/mailman/listinfo/sks-devel
Reply | Threaded
Open this post in threaded view
|

Re: noauth sks issue

Jens Leinenbach
Hi Gab,

>> 2009-12-15 20:50:21 Error handling request
>> (GET,/pks/lookup?op=index&options=mr&search=google,com,[
>> host:127.0.0.1:11371]): Invalid_argument("Too many responses")
>> 2009-12-15 20:50:21 Error handling request
>> (GET,/pks/lookup?op=index&options=mr&search=google.com,[
>> host:192.168.1.2:11371]): Invalid_argument("Too many responses")

This means that you searched for a PGP key of every person with an
google.com account. Answer: Too many to show all.

>> 2009-12-15 20:50:25 Error handling request
>> (GET,/pks/lookup?op=index&options=mr&search=gabrix.ath.cx,[
>> host:192.168.1.2:11371]): Sys_error("Broken pipe")

I think that means that your database was unreachable.

>> 2009-12-16 03:06:26 Malformed entry

You may see this for every line you commented out in your membership
file although it should be ignored.
Haven't seen this since version 1.1.1.


>> 2009-12-15 20:50:08 Raising Sys.Break -- PTree may be corrupted:
>> Failure("add_to_node: attempt to reinsert element into prefix tree")
>

Your PTree database broke. Happend to me regularly until I upgraded to
version 1.1.1.

Try this:
Stop SKS eg. with /etc/init.d/sks stop
Stop monit if you use monit for SKS, too.
then
cd /var/lib/sks/PTree

Now try to repair the database with:
db4.6_recover -e -v

If it doesn't help, try:
db4.6_recover -e -v -c

If this doesn't help, too, try to rebuild the PTree database. E.g.
/usr/sbin/sks pbuild -cache 20 -ptree_cache 70

Wait and retry.


Cheers,
Jens



_______________________________________________
Sks-devel mailing list
[hidden email]
http://lists.nongnu.org/mailman/listinfo/sks-devel