[patch #8216] Require gettext 0.17

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[patch #8216] Require gettext 0.17

Eric L.-2
URL:
  <http://savannah.nongnu.org/patch/?8216>

                 Summary: Require gettext 0.17
                 Project: WeeChat
            Submitted by: mopsfelder
            Submitted on: Thu 24 Oct 2013 12:30:56 PM GMT
                Category: compilation
                Priority: 5 - Normal
                  Status: None
                 Privacy: Public
             Assigned to: None
        Originator Email:
             Open/Closed: Open
         Discussion Lock: Any
                IRC nick:

    _______________________________________________________

Details:

RHEL 6 has gettext 0.17 and it is able to build weechat 0.4.2 using this
version of gettext.  There is no real need for 0.18 as introduced by commit
a3cc9bbe7e5dc868223f87471d1b569506341c86.



    _______________________________________________________

File Attachments:


-------------------------------------------------------
Date: Thu 24 Oct 2013 12:30:56 PM GMT  Name: 0001-Require-gettext-0.17.txt
Size: 951B   By: mopsfelder

<http://savannah.nongnu.org/patch/download.php?file_id=29458>

    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/patch/?8216>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/


_______________________________________________
Weechat-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/weechat-dev
Reply | Threaded
Open this post in threaded view
|

[patch #8216] Require gettext 0.17

Eric L.-2
Update of patch #8216 (project weechat):

                  Status:                    None => Wont Do                
             Assigned to:                    None => flashcode              

    _______________________________________________________

Follow-up Comment #1:

Hi,

I'm not able to compile with gettext 0.17 since it's not available on my
Debian (I have only 0.18).

Anyway, you should NOT compile with autotools unless you have a good reason to
do that (autotools may be removed from WeeChat in future).
Cmake is the preferred way to compile weechat, and it should work with any
version of gettext.

If you really can't use cmake (which is better and faster than autotools),
then I guess you'll have to patch the configure.ac manually.
Or if you have a better solution that would work on a machine with only
gettext 0.18, please tell me :)

    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/patch/?8216>

_______________________________________________
  Message posté via/par Savannah
  http://savannah.nongnu.org/


_______________________________________________
Weechat-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/weechat-dev
Reply | Threaded
Open this post in threaded view
|

[patch #8216] Require gettext 0.17

Eric L.-2
Follow-up Comment #2, patch #8216 (project weechat):

Hi Sebastien,

AM_GNU_GETTEXT_VERSION checks for a minimum version.  So having it to check
for 0.17 will pass on systems with gettext >= 0.17.

But I can live with the fact autotools will be removed from weechat.

You may close this.

    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/patch/?8216>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/


_______________________________________________
Weechat-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/weechat-dev
Reply | Threaded
Open this post in threaded view
|

[patch #8216] Require gettext 0.17

Eric L.-2
Follow-up Comment #3, patch #8216 (project weechat):

I tried, but I got this error, and I have no idea how to fix that:


*** error: gettext infrastructure mismatch: using a Makefile.in.in from
gettext version 0.17 but the autoconf macros are from gettext version 0.18


    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/patch/?8216>

_______________________________________________
  Message posté via/par Savannah
  http://savannah.nongnu.org/


_______________________________________________
Weechat-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/weechat-dev
Reply | Threaded
Open this post in threaded view
|

[patch #8216] Require gettext 0.17

Eric L.-2
Follow-up Comment #4, patch #8216 (project weechat):

The full error (problem with verbatim formatting):

*** error: gettext infrastructure mismatch: using a Makefile.in.in from
gettext version 0.17 but the autoconf macros are from gettext version 0.18

    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/patch/?8216>

_______________________________________________
  Message posté via/par Savannah
  http://savannah.nongnu.org/


_______________________________________________
Weechat-dev mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/weechat-dev