startup troubles

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

startup troubles

Skip Carter
I am having trouble with the startup file /etc/init.d/sks,
the sks db part fails with:

Fatal error: exception Keydb.Unsafe.No_db
Fatal error: exception Unix.Unix_error(63, "connect", "")

but when I execute it directly in works:

 sks -debug -stdoutlog db
2019-05-30 09:17:27 sks_db, SKS version 1.1.5
2019-05-30 09:17:27 Using BerkelyDB version 5.3.28
2019-05-30 09:17:27 Copyright Yaron Minsky 2002, 2003, 2004
2019-05-30 09:17:27 Licensed under GPL. See LICENSE file for details
2019-05-30 09:17:27 http port: 11371
2019-05-30 09:17:27 address for ...(peer data)
2019-05-30 09:17:29 address for ...(peer data)
2019-05-30 09:17:29 address for ...(peer data)
2019-05-30 09:17:29 address for ...(peer data)
2019-05-30 09:17:29 Opening KeyDB database
2019-05-30 09:17:29 Database opened
2019-05-30 09:17:29 Applied filters: yminsky.dedup


 
My environ:

Debian

apt-get install libdb-dev           installed bdb-5.3
apt-get install ocaml-nox           installed OCaml version 4.01.0
apt-get install sks                 installed SKS version 1.1.5

--
Dr Everett (Skip) Carter
[hidden email]

Taygeta Scientific Inc
607 Charles Ave
Seaside CA 93955
831-641-0645 x103



_______________________________________________
Sks-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/sks-devel

signature.asc (673 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: startup troubles

Todd Fleisher
Before trying to tackle the issue you are having with the init script, I believe you will want to install the latest SKS version 1.1.6 (Release notice: https://lists.nongnu.org/archive/html/sks-devel/2016-08/msg00000.html). You may also want to look into installing the package that has a few patches for the original, so-called “poison keys” that will almost certainly cause your system to be unstable & use much more bandwidth & IO than is necessary. More info on that can be found @ https://lists.nongnu.org/archive/html/sks-devel/2018-07/msg00053.html & https://launchpad.net/~canonical-sysadmins/+archive/ubuntu/sks-public/+packages actually has packaged versions with the patch for Ubuntu which may or may not work for you out of the box on Debian.

-T

On May 30, 2019, at 9:33 AM, Skip Carter <[hidden email]> wrote:

2019-05-30 09:17:27 sks_db, SKS version 1.1.5



_______________________________________________
Sks-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/sks-devel

signature.asc (849 bytes) Download Attachment