unresolved problems on latex with emacs-wiki

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

unresolved problems on latex with emacs-wiki

Hui Zhou-2
Thanks a lot for Stefan's suggestion.  I have tried that, but the same error happens. Any other guess/suggetion on what the problem may be? I really appeciate that
 
btw: the emacs loads the latex2png.el and several other files correctly, and I have installed the tetex-bin, tetex-extra. 
 
All the best,
 
Hui
 

Message: 2
Date: Wed, 4 Oct 2006 16:57:39 +0200
From: Stefan van der Walt <[hidden email]>
Subject: Re: [emacs-wiki-discuss] help needed on using latex with
       emacs-wiki
To: [hidden email]
Message-ID: < [hidden email]>
Content-Type: text/plain; charset=iso-8859-1

Hi Hui

Just create a latex sub-directory in your output directory.  Also, I
think you may want to change your code to have only one surrounding $,
i.e.

<latex prefix="Ma">$a = 0$</latex>

Hope that helps.
Stéfan

On Wed, Oct 04, 2006 at 12:20:45AM -0700, Hui Zhou wrote:

> Hi there,
>
> I have been confused for quite a while by using latex formula in emacs-wiki.
> You help is really appreciated on that.
>
> I have downloaded the necessary *.el files and configured my .emacs file as
> instructed on http://www.sfcu.ca/~gswamina/EmacsWikiBlog. However, when I try
> the following simple expression in a wiki page
>    <latex prefix="Ma">
>        $$ a = 0$$
>     </latex>
> I get the error message as
>  "Failed to create png file
>   The latex folder does not exist!
>   * emacs-wiki-tmp*: Error occurred: (wront-type-argument integer-or-marker-p
> nil)
>
> I have auctex properly install on my ubuntu system and I can properly preview
> latex in latex-mode.  So I really have no idea what can be wrong with that. Any
> suggestions?
>
> Thanks,
>
> Hui
>
>
>


*************************************************


_______________________________________________
emacs-wiki-discuss mailing list
[hidden email]
http://lists.nongnu.org/mailman/listinfo/emacs-wiki-discuss