version being reported incorrectly?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

version being reported incorrectly?

duplicity-talk mailing list
I installed the latest duplicity:
python setup.py install --prefix=/usr/local

then check it:
ls -lrt /usr/local/bin/duplicity

-rwxr-xr-x. 1 root root 62307 Dec 31 08:33 /usr/local/bin/duplicity


which duplicity
/usr/local/bin/duplicity

/usr/local/bin/duplicity -V
duplicity 0.7.05


huh? Why is this not showing version 0.7.11 ?




_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk
Reply | Threaded
Open this post in threaded view
|

Re: version being reported incorrectly?

duplicity-talk mailing list
If you install manually from trunk (did you?) you will get:

ken@dione:~$ duplicity -V
duplicity $version

Looks like you have an old version still.  Use your package manager to uninstall/purge the old version, then reinstall manually.

...Ken


On Mon, Jan 30, 2017 at 2:05 PM, Scott Classen via Duplicity-talk <[hidden email]> wrote:
I installed the latest duplicity:
python setup.py install --prefix=/usr/local

then check it:
ls -lrt /usr/local/bin/duplicity

-rwxr-xr-x. 1 root root 62307 Dec 31 08:33 /usr/local/bin/duplicity


which duplicity
/usr/local/bin/duplicity

/usr/local/bin/duplicity -V
duplicity 0.7.05


huh? Why is this not showing version 0.7.11 ?




_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk


_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk
Reply | Threaded
Open this post in threaded view
|

Re: version being reported incorrectly?

duplicity-talk mailing list
or follow the 'INSTALL MULTIPLE VERSIONS' instructions on
  http://duply.net/wiki/index.php/Duply-documentation

always a good idea to keep the old, just in case ;).. ede/duply.net

PS: your system duplicity is mashed up now. you should clean and reinstall it anyway.

On 30.01.2017 21:24, Kenneth Loafman via Duplicity-talk wrote:

> If you install manually from trunk (did you?) you will get:
>
> ken@dione:~$ duplicity -V
> duplicity $version
>
> Looks like you have an old version still.  Use your package manager to uninstall/purge the old version, then reinstall manually.
>
> ...Ken
>
>
> On Mon, Jan 30, 2017 at 2:05 PM, Scott Classen via Duplicity-talk <[hidden email] <mailto:[hidden email]>> wrote:
>
>     I installed the latest duplicity:
>     python setup.py install --prefix=/usr/local
>
>     then check it:
>     ls -lrt /usr/local/bin/duplicity
>
>     -rwxr-xr-x. 1 root root 62307 Dec 31 08:33 /usr/local/bin/duplicity
>
>
>     which duplicity
>     /usr/local/bin/duplicity
>
>     /usr/local/bin/duplicity -V
>     duplicity 0.7.05
>
>
>     huh? Why is this not showing version 0.7.11 ?
>
>
>
>
>     _______________________________________________
>     Duplicity-talk mailing list
>     [hidden email] <mailto:[hidden email]>
>     https://lists.nongnu.org/mailman/listinfo/duplicity-talk <https://lists.nongnu.org/mailman/listinfo/duplicity-talk>
>
>
>
>
> _______________________________________________
> Duplicity-talk mailing list
> [hidden email]
> https://lists.nongnu.org/mailman/listinfo/duplicity-talk
>

_______________________________________________
Duplicity-talk mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/duplicity-talk